• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


casper76

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About casper76

  • Rank
    Newbie

Profile Information

  • Ford Model
    2006 Focus TDCi Ghia
  1. pollen filter

    Sorry Ignore me and my post it wrong, Thought I was in the Focus forum!!!!!! Apologies Casper
  2. pollen filter

    Changed mine today. First you have to drop the fuse box. then remove the bracket which holds the fuse box. 2x 13mm nuts. You will then see the cover of the pollen filter, look left at the bottom behind the centre console area. It is held in by 2 torx screws or a third if you car is fitted with a chilled glove box. It is very fiddly and you will need to bend into shapes and places you didn't think possible!!!! Good Luck Casper
  3. Focus Diesel Poor MPG

    Thanks for the advice. The blue smoke is only seen on start up, then every time the car is started afterwards there is no smoke or rough running? Worryingly it has been into a Ford dealer who said they could only find the fault with the fuel pressure sensor? Thanks Casper
  4. Focus Diesel Poor MPG

    Hello, I have an 06 Focus 1.8 Diesel. Recently it has suffered from a lumpy engine when started from cold. When I rev the engine it is very rough and blue smoke poors out of the exhaust. Also the MPG has dropped dramatically from 54 to 47 MPG? It has been into the garage and they diagnosed low fuel pressure. It was traced to the fuel pressure sensor having a poor conection which has supposedly been rectified. Also they updated the software as this had never been done. It still has poor MPG, below 50 MPG! I throw this open to the floor, has anyone else had this problem or any ides of the cause/solution... Fingers Crossed Casper