Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


ferguswalker

Budding Enthusiast
  • Content count

    11
  • Joined

  • Last visited

About ferguswalker

  • Rank
    Member

Contact Methods

  • First Name
    Bruce

Profile Information

  • Gender*
    Male
  • Ford Model
    Focus CMax
  • Ford Year
    2005
  • UK/Ireland Location
    Roxburghshire
  • Annual Mileage
    5001 to 10,000
  • Interests
    Classic Cars
    Car Restoration
    Literature

Previous Fields

  • Location
    Hawick
  1. Sorry for delay. Been away for some time! One of the injectors is now leaking fuel! Taking it to another garage. No torque before 1800revs, sluggish going up hill - never before have I had to change down to third going up a certain hill! Max MPG 50 on long run. Down to 34 urban. It is no pleasure to drive anymore Jeebo!
  2. I'll take that advice - many thanks!
  3. Meant to add that I have taken it back to the garage and they have checked the injector wiring/connections and they have had it on their computer. They did not take the injectors out to check them though. But if any one was faulty would that not make the engine misfire or, at the very least, run roughly?
  4. Thanks James. I have to take it for a long run tomorrow so will see if there is any improvement - but it is running ever so smoothly - no misfire or leaking fumes.
  5. Ford Cmax 1.6DCi 2005. Garage recently changed cam belt and refurbished injectors as fumes coming into car. Fixed the exhaust gas smell but car lacking power and fuel consumption fallen through the roof from 52 mpg to 34mpg - sluugish on acceleration but otherwise as smooth as silk. They have re-checked evrything (not cam belt) and reset the computer. No difference. Anyone have any ideas? For instance, is it possible the cam belt has not been put on properly and the timing is out?
  6. Just been told that my coolant fan is on way out. New one costs £350!! So down to local breakers yard and picked one up for £36. Now the problem - how do you get the old one out and the new one in? My Cmax is a 54 plate 1.6 DCi Duratorc with the particulate filter so the fan is offset within the cowling. There is not much space at the front of this engine so is this an "underneath" job? Anyone done it - successfully? Oh, and the engine management light is on again just one day after having a DPF sensor replaced. Thanks
  7. Hi Louise As your car is not creating its own oil the only alternative is that water is seeping in perhaps through a failed cylinder head gasket - although it is usually the other way round with the high pressure oil pushing its way into the coolant. Are you going through coolant? Water will fall to the bottom of the sump with the oil floating on top giving the appearance of an increased oil level. Any discolouration of the oil visible? When water mixes with oil and is "thrashed" about inside the engine it can form an emulsion which is either grey or white. If this is happening then it could result in your turbo failing as this runs at a very high temperature and needs a good supply of uncontaminated oil. And, sorry if I sound harsh, but you do not want your turbo to fail totally. I have a CMax now my previous car being a Megane 1.9 dci. It blew up, literally - the turbo failed and I tried to turn the engine off with no success, the engine raced as it was feeding, now, on the engine oil and after a lapse of 20 seconds I realised I had to staff the engine to stop it. However by that time it was too late and the engine was u/s. So have it checked out by another garage and do not tell them what the previous garage said to you.
  8. Ford C-Max 1.6 dci manual 54 plate. Having same "hunting"/"power loss" problems experienced by many in this forum topic - is there no hope for us? Been in the local Ford garage but as you might expect, the problem persists. What is the prognosis? Any one had success with changing the chip and at what cost? Has Ford ever acknowledged the problem?
  9. Sorry to have to bring this subject up again but it has happened in my 54 CMax 1.6 DcI. Over the past few months I havew noticed a distinct "hunting" on low rev acceleration and this has got worse over the period. Now, today, having been stationery but ticking over for 15/20 mins, the engine cut on acceleration. It started again but kept cutting out until the "Steering Assist Failure" warning came up - no other warning lights though. Managed to get it home. Could the "hunting" and the steering fault be linked? Anyone with any ideas on the suibject? Thanks
  10. Recently purchased a Ford Cmax 1.6 DCi from a reputable leasing firm - was used by my brother-in-law who works for a Government agency who lease cars for their staff. Full service history, serviced by a Ford main dealer. A few weeks ago a warning light appeared on the dash. Took it to a Ford dealer near where I live to be told that the fault lay with the DPF which should have been renewed during ther 75k service but had not been replaced. The service history book is fully stamped by the Ford dealer. Replacement of this DPF will cost over £1k. Rather annoyed with lease company who have offered £250! This does not even cover the cost of the service at my local dealer who diagnosed the problem in the first place! Isn't it fraudulent to stamp a service register when the work has not been done. Can anyone offer any advice as to how to persuade the leasing company to get this work done?