FORD 1

Budding Enthusiast
  • Content count

    10
  • Joined

  • Last visited

About FORD 1

  • Rank
    Member

Profile Information

  • Ford Model
    S MAX
  1. Thanks but my problem is that when I select the right or left indicator with the stalk absolutely nothing happens intemittently. A wiring or bulb fault causes the indicators to flash rapidly. I seem to have a failure of whatever electronic gizzmo feeds the indicators so would like to know what that is and where is it please? Thanks
  2. Hi, SMAX 2.0 TDI 2007 34K Just recently the right indicator stopped working, i.e. nothing happened when i operated the stalk. After a short while they started working. Then a few days later the left side failed and then worked again a few minutes later. Even whilst they were not working the Hazaards were ok. The bulbs are ok, in fact I took one out and noted the indicators still worked with a faster flash, so I'm wondering if there is a flasher relay which has nothing to do with the hazaards somewhere I can replace? Also, sometimes when I start the car the instrument panel says " front lights malfunction" for a couple of seconds but all the lights work? Interestingly when the indicators are not working there is no warning caption on the instrument panel? Thanks
  3. My Smax Titanium is 3.5 years old and has therefore just slipped out of warranty. Last month the engine malfunction light came on accompanied by loss of power and a machine gun type noise. The dealer has removed the cylinder head which revealed some bits of metal in one cylinder which have extensively damaged the top of the piston and the valves and surrounding cylinder head face. There was no compression from this cylider so they are going to remove the piston expecting to find a broken piston ring. Given that the warranty has only just expired and the vehicle has only done 28k miles we are seriously angry. I would appreciate advice on how to tackle Ford over this? I don't just want some goodwill I want them to fund the repair. I believe the sales of goods act stipulates items less than five years old last a reasonable time. Does anyone know the legal term and maybe sales of goods act reference so I can quote it in a letter. In case I have no luck does anyone know a source of recon engines or someone who can repair mine. I believe the recon people require an exchange engine, would the damage to mine preclude that? Thanks
  4. That will be the button on the dash? The manual says that when selecting reverse the system is automatically turned on. The button is so that when in a forward gear you can turn the system on to activate the front sensors i believe. The beep when selecting reverse coupled with a flashing light in the button indicates a fault in the system. I'm hoping someone can tell where the control module is located and is there just one module for front and rear? Thanks
  5. Hi, The parking sensors on my 2007 tdi Titanium do not work. When selecting reverse I get a 3 second beep and the dash switch flashes. I would like to check the wiring all the way from the sensors to the control module so can someone please tell me where the module is located and is there one for both front and rear? Thanks
  6. When my A3 did the same it was the diesel particulate filter on the exhaust.
  7. I've since ordered a set of 4 new front sensors with mounting kit and hardware, problem is I can't see where the inner two are located, looking at photos of other titaniums the outer two are obvious but where do the inner two mount?
  8. My 2007 S MAX has previously had a shoddy repair to a front end smash, it looks like an incorrect bumper has been fitted which looks ok but does not have the two parking sensors fitted. The rear 4 are present but the system does not work, i.e. on engaging reverse I get the 3 second tone and flashing light in the switch. So am wondering if the system can be made to function using the rear sensors only or if not, where can I buy two new front sensors ( part number?) without going to Ford? If I do get two replacements I'm not yet sure if the wiring is present for them, if not where is the parking sensor box located please? Thanks
  9. I have the same problem on a 2 year old s max, very disappointing. All the Blaupunkt specialists say to go to Ford. Blaupunkt in Germany say the same thing. Can't imagine Ford will be able to repair it so they will probably try to sell me a replacement at circa £1k I guess. Would really appreciate any advice on getting this fixed and also how to remove it? Also got a black line on the odometer display so that needs fixed too, any help with fixing/ removing that would be appreciated too? Thanks