Natalie1310

Budding Enthusiast
  • Content count

    8
  • Joined

  • Last visited

About Natalie1310

  • Rank
    Newbie

Contact Methods

  • First Name
    Natalie

Profile Information

  • Gender*
    Female
  • Ford Model
    Fiesta
  • Ford Year
    1996
  • UK/Ireland Location
    Essex
  • Annual Mileage
    0 to 5000
  1. Ah this site got targeted by the mass PM too? Seems a large amount of IPB forums got targeted by this same user. Also happened on another IPB forum that I belong to.
  2. I put in 10w40 last night. The choice was either 10w40 or 15w40 and the little handbook laying next to the oil in the shop also suggested the 10w40 stuff so I'll see how it goes this morning. Indeed I'm a little worried as to where the oil went. I've never had to top it up myself before. Then again I had a lot of starting problems last winter so it ended up at the garage a lot with oil changes and having a whole new sump fitted. But it didn't dissapear during the summer so who knows. No it's fine. Having reminders is a good thing. Also helps those that may read this in the future that do not know. It was just a case of know one had really answered my question. Yes it was stated just top it up but not does it matter that the old oil is possibly different. I was just purely paranoid as it's such a temperamental car and has given me so much trouble in the year that I have owned it. Really it's time for a new one. Thanks for the help everyone anyway. It's put my mind at ease.
  3. Electrical problems turned out to just be cold minus the heater lights not coming on unless I bash them which has been a problem for a long time. As far as the oil goes. 1. I know what oil I can use. 2. I know how to put oil in the car 3. I know how to check how much oil I have 4. I know the dangers of running on the minimum mark and having too much. My question was not knowing what oil my mechanic put in when he serviced it back in October is it ok for me to just top it up with the new stuff or is it better that it's drained so oils aren't mixed? I'm just extremely paranoid due to the amount of troubles this car has given me since owning it (it hates the winter). And as I said this winter it has really behaved itself and I don't want to ruin that now.
  4. I'm just being paranoid here due to the large amount of problems my car has given me. It has been extremely well behaved this winter despite the severe cold and I don't want to ruin things now! Never having done this before myself I'm a little scared of doing it. Yesterday when filling up my washer fluid bottle I'd thought I'd check all my other levels as well to discover my oil level is right on the minimum mark so I need to top up. No idea how long it's been like that so I am a little scared of driving it now although I have no choice as I have to drive it everyday to work. Might pop down to Halfords to go buy some at lunch time today. Now what I am unsure about is will I get away with just topping it up not knowing what oil my garage put in or is mixing oils not a good idea? So is draining the oil totally and then putting in new a better idea? On a side note which I should probably ask somewhere else I have a few minor problems with my electrics which I am suspecting a fuse has gone and maybe a loose wire. Probably will get it checked out in the next few weeks but as they are so minor I'm in no hurry. 1. When opening the door with my headlights on I'm no longer getting a warning sound. 2. The first time I put my car in reverse the reverse light doesn't appear to come on until I've moved a few feet. After that it comes on fine every time. 3. Occasionally the lights in the central console do not come on (heater lights). I give it a bash and it comes on. The heater itself is working fine. 4. Interior light when opening the door - this is no longer coming on for either driver or passenger doors. The switch is definitely in the correct position. Pressing the button in the door does turn the light on but if you then close the door and open it again the light fails to come on. Any ideas? 1996 mk3 Fiesta by the way
  5. I still haven't had it looked at :D well I kind of did. When I put it in for it's MOT they said nothing was wrong and it apparently would have failed if something was wrong (they claimed they couldn't hear anything either - it was quieter at the time however). Anyway strangely since the cold weather my steering has shut up totally but has become really loose (put that down to the icy roads though) and feeling kind of strange on the tight bends (lots of them on my journey to and from work). It just seems to be temperamental as some days it behaves and some days it doesn't. At some point when it gets noisy again I will get a second opinion. It sounds like some kind of lubrication problem like a rubbing noise so what you are saying makes sense. It's not one sided either, the rubbing noise I get turning both ways. The steering seems to have been a very old problem (although I noticed no problems for the first few months I owned the car). I found the invoices the previous owner kept and several are steering related. As of 19/12 the noise is back again!
  6. 1996 P reg Fiesta LX 60,000 miles. First a bit of history. Last winter I had a lot of problems with the engine starting. Every now and then I would get in my car in the morning to go to work and then find that it did not start. Prior to that I had stalling problems at junctions as I went to stop. No one ever worked out what the reason for these problems were. First my car's version of the carburettor (apparently it doesn't have one) was supposedly dirty. That was cleaned up and filters changed. Next the car was re-wired, I can't remember exactly but the wiring was supposedly corroded. Then I had a mobile mechanic change the spark plugs and he snipped the end off one of the hoses which had a split. The final time which was in March I noticed there was creamy gunk in the oil, that apparently was just condensation. Let it sit a couple of days and it started again. I had no problems what so ever during the summer until yesterday. After the cold and snow event of yesterday morning I decided OK let's check that my car is OK seeing as I had protected it with a cover this time to try and prevent the damp getting in (I shoved it in the bonnet though as it's too big for my car and the wind blowing it about would have drove the neighbours crazy). It didn't survive. The car is refusing to start. I had a mobile mechanic round today who couldn't get it going but did some tests saying he has a feeling that it could be a problem with the ECU and has been all the time. He couldn't find any problems mechanically and said he ran some tests which is why he suspected this but being a mobile mechanic he couldn't fix and said it needs taking down to a garage to be plugged in to have the electrics and ECU checked over. So I found a auto electrics place who kindly said they will come pick my car up for me tomorrow. I thought it's best getting them to look rather than my normal garage as they specialise in electrics. So the question is if the ECU has failed is it worth getting it sorted? Is it a big job? Expensive? EDIT 25/11/2008: Appears to have just been damp and cold again taking 2 days to dry out like last time. Garage came to pick it up, tried starting it and it started. Any tips for keeping it dry as plastic in the bonnet didn't work? I don't have a garage.
  7. Nope
  8. I'm losing my patience with this car now have had so many problems (have probably paid around the amount i bought the car for in repairs now), the most recent being the steering. Around March my steering started creeking badly and then locked up totally. Turned out to be that one of the steering joints had gone. Great steering freed up and noise gone. Then a few days later the creek starts to come back, the smoothness dissapears, doesn't lock up but is kind of rigid in its movements if you get what I mean, also developed a popping noise and the wheel wasn't straight. Got that looked at in a different garage they said nothing is wrong except suspension ball joint was gone, got that replaced, no change (I wouldn't have thought that would make any difference anyway, just probably something they noticed while they were looking). So I just left it for a while until I got round to getting it looked at again and it started deteriorating some more, latest symptom was the left indicator turning itself on when doing extreme turns to the left (not always though). Got that fixed Wednesday, turned out to be the whole steering rack had gone. So good for a couple of days, silent, lovely and smooth, but today it started creaking and stiffening up again, 2 days after I got it fixed. Still nice and smooth to turn however, just stiffer. I don't get it. Surely it can't be the other joint going? Surely they would have seen that when replacing the rack? Any ideas? 1996 P reg 1.1 LX by the way. I'm beginning to go by the attitude of it's old, live with it's creaks.