davd

Budding Enthusiast
  • Content count

    11
  • Joined

  • Last visited

About davd

  • Rank
    Member

Profile Information

  • Ford Model
    mondeo
  1. thanx for the guidance mate! the link u sent looks quiet easy to follow. will start work on it once the weather gets better, as for the injectors, after iv cleaned out manifold and see how it runs ,then its time for the injectors to be sorted if it still persists!the info about the injectors u sent is very enlightening! il put up post once iv done all this work with the results! thanx again, god bless!
  2. hi ralph had a new intercooler pipe put on last year, and took off egr, was clogged up like a good un but cleaned it up etc ,left it in petrol overnight and freed it up and put it back on,,this was all done last year! so what im asking is could it be the actual manifold thats clogged up??? and with regards to the knocking, i think and have been told it could be 1 of the injectors?? which 1 usually goes on this particular engine and whats the firing order of the injectors, ps ,sm1 told me thats is usually the injector nearer the timing belt that usually goes????? some of your enlightening guidance wont go amiss mate!!! thanx!!
  3. few problems i think! on starting cold, its spitting and farting, missing ! once warmed up idles ok , but missing a bit! knocking sound when pulling off, not the tensioner noise! sounds like injector knocking! and 2nd problem is, boost pressure i think! got the code read and it was boost pressure problem! when im driving from cold and have the turbo come in ,power comes through then suddenly into limp mode,glow plug lite comes on! i switch off and on again and lite goes out and carry on but got to be careful not to build up high revs whilst driving because once turbo kiks in if i carry on accelerating to high revs turbo cuts out and goes into limp mode????thus im not utilising the full revs and power! but once the motor is properly warmed up i have no problems at all??? the injector knocking is always there but is reduced once the car is warm! how do i know or test which injector is gone??? and is it a common problem associated with a certain number injector,be it 1 ,2 ,3 or number 4 injector? with regards to the turbo cutting out,iv been told it could be a gummy turbo or it could even be a leak or it could be a sensor??? how do i nail this problem or narrow down the fault finding, please help!!! david
  4. tensioner, all day long! its normal for mondeos, for some reason when you start them from cold they cause a racket, as you drive and warm up the noise slowly goes away! replace tensioner and belt! im living with mine until its proper !Removed!! lol
  5. ok if its smoking ,check your intercooler pipe , might be split thus causing the loss of power and smoke,,the pipe is located to the left of the radiator, and goes down parallel to the rad! if it aint that or you cant find no splits then get your erg valve cheked, its probably clogged up,,get it taken off and cleaned with petrol,,dip it in petrol and clean it up properly! if its not that then might be a turbo problem ,sometimes they start playing up etc ,it could be the fins are stiking?? good way to chek is to drive the motor and have the window down and wen the turbo cuts in at about 2000revs you can hear it,,,,if its making a clattery noise that means your turbos playing up, if youve got a glow plug light on the dash that is flashing or a engine management lite flashing ,get the code read from a code reader,,some bak street mechanics do have them and then get bak to me with the codes or just look them up on the net!! david
  6. u activate d rain sensor by leavin the wiper stik in position two ,ul know its on by puttin the ignition on and the wipers will giv u 1 turn,,even if its sunny,once u start the motor the rain sensors are active and wen a drop cums down,,they shud kik in!!!try it
  7. its a very contraversial engine,we all gt the same problem lol,,ask any mondeo owner,,theirs a genius on this website called mintalkin,,thats his user name,,,get in touch with him ,,and he will guide you right!!!look him up!!
  8. i forgot on my previous post,,i lost the cd to the touch screen sat nav,,can i download 1 anywhere on the net or buy 1 etc ,,without getting ripped at the dealership???? thanx david.
  9. the car was initialy smoking from the exhaust,,its done 94k miliege,,after taking some good advice and guidance from 2 geniuses from this forum i replaced the inter cooler pipe which was split,and cleaned out the egr valve which was clogged up ,,replaced the egr valve to its posiition,,the smonke was dramaticaly reduced,,mechanic attached his read out instrument to check on the codes,,and the following read out codes wer displayed,,p0409 p0404 and p2263,,on accelelaration it sounds as though its missing slightly,,as i decelerate it lets out a liitle puff of smoke from the exaust,,,,its still smoking slightly,,the glow plug light remains on,i was also adviced that becuse the glow plug light remains on it doesnt nessacerally mean the glow plugs are knakerd ,it could mean something else???,could it be a injector???and can some one tell me, have i gtta update the software on the ecu???do fords update d software on their ecu???some manufacturers do!!is it advisable to update software if its available and if it is ,,is there other places i can go to get updates apart from dealerships????due to my budget!!iv also read on the forum abt this famous knockin sound comin from the 2.0tdci 130 duratorque,,its hapenin to mine but goes away once its warmed up,,wats d kit called and isit only a dealer ship part and how much,,another headache is that the electric seat keeps blowing fuse,,was told motor on seat must be knakerd,,looked underneath seat ,,which one is the motor that electicaly pushes d seat forward and bak as i have long legs and need to adjust appropriately,,its a 30amp fuse,,, i wa adviced abt the smokin and told to tank up on top of the range diesel and chuk sum injector cleaner in and take her for a long run,,get all d soot and crap out of the system,,im doing that 2morrow! can all and sundrry that know abt these faults and problems advice me and guide me on these particular headaches,,i have a very low budget due to arrival of new born!!!! david
  10. turbos not cutting in at required revs!!!!it just starts smoking,,its done 70 000 odd miles !!!!has any 1 had similiar problems with this engine????need some advice to rectify the problem!!!could it be sumthing else???like a sensor or sumthing else,,,dont really know where to start and i dont wnna be ripped off by the dealers!!!!i have had diesels in the past that have done far greater milege with no problems with regards to the turbo!!!the car still drive ,,,but i gtta avoid puttin my foot down,,as the smoke starts to billow out,,,plz plz help!!!!!