AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


nic133

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About nic133

  • Rank
    Newbie

Profile Information

  • Ford Model
    Fusion
  1. Hi. Thanks for the replies. Just a few updates. My car is the facelift with the cubby hole above the glovebox. I have replaced the indicator stalk with a second hand one (£20 from breakers and off a mk6 fiesta as it happens), and this has worked and the button is now fully working. As for cig lighter, fuse is fine, so its either needing the fins bend inward, or just replacing which i suspect i'll end up doing. The mirror seems completely knackered, its a sealed unit and only has one fuse operating it (1 fuse operates both sides). I've currently pulled the fuse to save the embarrasment of the grinding noise every time you lock the doors. A new mirror from Ford is £118 inc vat, or an aftermarket one off ebay is £50 plus postage. Not decided what one to go for yet, any ideas? Until i make my decision i'll keep the fuse pulled out. Thanks again Chris
  2. Hi guys, I'm new to Ford Ownership and just picked up a pretty decent spec 56 reg Fusion 3 + 1.6. First impressions are good, although only had it a few days, but have noticed a few problems, which i hope you guys can help me with. - First up is the trip computer wont work. When i got it the dash display was stuck on the 'Range' setting, so i disconnected the battery and its reset to the trip computer, but still wont work. The button on the end of the indicator stalk deosnt do anything, when i assume its supposed to. Do we think a new stalk will fix this? - Secondly is the passenger power fold mirror. It still folds, but as it gets fully folded in it seems to try to carry on folding and makes a loud grinding noise (almost a !Removed! noise), any ideas what this could be or how to fix it? - Last of all the 12v power point in the front isnt working, hopefully just a fuse. Hope to be around on the site for a while, and who knows, one day i may be able to answer some questions too lol. Thanks Chris