AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


click cluck

Budding Enthusiast
  • Content count

    17
  • Joined

  • Last visited

About click cluck

  • Rank
    Member

Profile Information

  • Ford Model
    mondeo tdci
  1. sorry If not following protocol... I have a "F-super" scanner bought a few years ago ( from ebay via beatthegarage.co.uk ) for use with my mondeo 2 tdci saved me 1000's ( as well as paying local diesel specialists who charged me £70 fo NO better info and informed me it was a £1,200.00 turbo replacement job!!! ) - I got turbo injector solder repaired for £5... any who - I have lost the ( will to live nearly.... ;-) ) software to make it work!!! i KNOW IT HAS BEE DISCUSSED here but links I found for downloads do not work / are corrupt.. any help?
  2. sounds like (!!) the tensioner pulley and or crank - classic symptom = noisier when air con is on. ok to leave - just put up with noise - mind you if bushes are / have failed I suppose eventually something will break!! but not urgent
  3. http://www.talkford....ttach_id=118611 PHOTO OF LABELLED ENGINE PARTS...
  4. EGR valve is bottom left - follow the pipe work from turbo to intercooler ( under rad ) and up to EGR - two pipes go to it - one from intercooler ( fresh air from Turbo ) and another smaller metal one crosses in front of manifold ( from exhaust ) You will need a good too set to get all the nuts off!!! Just done mine - clogged up with gunge ( 50% restricted ) mad no difference Blanked off - no difference Symptoms - flashing heater , loss of power and fault 2263 - turbo pressure. Now taken off actuator and awaiting diagnosis... drives the same - no power / turbo!!
  5. It all started when I accidently started it in gear - then while accelerating onto motorway it didn't - would not accelerate much and heater plug light was flashing. got of M6 and stopped - restarted and fine. Ever since then it has been going into "limp mode" and loss of power - poor acceleration - the for a while all fine! tried so far. mates diagnostic - error 2262 Diesel "specialist" Delphi error 2262 I.e turbo lack of pressure... But turbo seems fine - turbo arm free.. - and specialist says never seen code before ( all over the web!!! ) So air mass swapped, injector cleaner ran through, ECR cleaned, NOT split inter cooler hose, Cam sensor changed Now if I rev - sat still - up to ~2000 rpm - and back off it gets VERY rough - horrible. Since changing the cam sensor the heater light has stayed off - but too early to tell. Engine management light on all the time Tried " twitching ign. on/ff 20 times" as advised on "johns" website - no worky... So - you think changing the cam sensor ( from a black one to a new grey!!) has worked? I don't want to waste another £60 ON DIAGNOSTICS TO FINE ERROR 2262 is / is not present - told me nothing the first time. Feels like a death rattle - Mind you it does most of the time ( long history of chasing more lemons round the crank shaft pulley / belt tensioner game ) If it ain't broke dont fix it - as long as it does not go into limp mode again
  6. yep mine done too... no more hunting clatter at tick-over Still noisy though!!! Normal cacophony + Sounds like a blown exhaust( but isn't = had it checked - Kind of a phat phat noise - any ideas - going to drive me mad this car - grunt and economy still good and love the drive - soft but handles well
  7. thanks crankshaft pulley - http://www.fordpartsuk.com/shop/mondeo_mk3_diesel_crankshaft_pulley_2450.htm or off ebay for £75 delivered
  8. Definitely seems like you need to replace all doing this job. Took mine to garage and they changed tensioner pulley only - declared crank pulley ok. Now 5k down the road I am getting belt slap - vibration / noise at tick-over and you can see the crank wobbling and see the belt flapping. So need to disassemble again to renew crank pulley - Thanks "Ford Specialist " garage Where's best to buy crank pulley??
  9. after every oil change I get variable but mostly high readings on dip stick. I have checked it 10 times at different times - all giving 1/2 " above max - only to find when I TAKE BACK TO GARAGE IT IS JUST AT MAX... all done on level ground, after a few mins or hours etc.
  10. Had this problem -Knocking noise - with air con on - that went away when off - so took to ford "specialist" who changed the tensioner pulley ONLY. Rubber bush was knackered in pulley assembly Cured the on / off noise but.... from what I read here they "should" have changed crank shaft pulley also - while they were there... now it has recently developed a " phat phat" noise at low revs / high load - blowing exhaust??
  11. I thought i WAS GETTING 50+ mpg - according to the dash board.. But checking by mileage and fuel pump it went down to 44. so instruments over read by 10% at least - and that's assuming the odometer is accurate!! 05 130 Tdci oh - btw - any idea why after every oil / filter change I should get erratic over-reads on the oil dip stick - as much as 1" over the max level - on level ground etc etc - but then ( usually when I take it back to garage!! ) the oil level is fine ( just max..)
  12. yep - OP said it was at idle..
  13. Why bother about this low ( 750 ) idle - If everything fine at 800 - idle at 800!!? - mine idles at 800 ( 2l tdci 130 ) but is rough even then - smooths out once it gets going.
  14. ?? Mine was noisy - turned out to be bush on tension cam gone - especially noticeable when AC turned on
  15. do not know - they ( garage) did not say what oil they used. It's dirty black oil by now anyway!!! I think the "Magnetic " oils stick on a microscopic level btw - certainly not enough to clog up dipstick tube... IMHO