Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


blinggully

Budding Enthusiast
  • Content count

    13
  • Joined

  • Last visited

About blinggully

  • Rank
    Member

Profile Information

  • Ford Model
    mk2 Mondeo
  1. Hiya Guys, Yesterday I brought a V reg 1.4 cl Focus, the car is great apart from the fact I have to use the key in the door to lock the car where my Mondeo was all of the key. Does my car not allow this as I have a simple standard key without the three buttons or can I buy a remote key and not know it or would I have to install loads of stuff just to get remote central locking??? Cheers Clinton.
  2. Everytime I get in traffic my temp guage seems to shoot up to half way on the guage after a few minutes of standing in traffic or barley rolling making me nervous its going to over heat, however when the tarffic clears which it has done for last few days after a few minutes thank god it soon shoots back down to minimum. I have plenty of antifreeze and water in it (do have a small leak when i fill it right up tho so i keep it too miniumum) and my interior heating soon warms up after a few minutes of being on so all fine there. This leaves me very puzzled and scared if I get stuck in serious traffic will my car continue to rise on the guage and blow up!!! Any ideas would be great and also can I check to see if my radiator fan works??? I am a novice mechanic by the way. Thanks Clinton.
  3. Over the last few days weirdly my revs tend to a little high especially on idle speed even when the engine is warm. Uusually sits just under 1000 but more 1500-1700 I would say. Even removed the Plenum chamber thing where the cable is and could not find any cable adjuster so puzzled me. Did the usual over checks like sparks plugs, oil, ht leads but everything seems in order especially as the car running is fine so problem is just the revs especially at idle speed. Any thoughts???
  4. Cheers FishPond lol....
  5. Obviously its brakes and would let someone with proper know how have a butchers at it. Not got time then I would check all the sensors on the wheels??? Failing that and desperate with little time....take bulb out!!!
  6. Anyone know how much fuel/miles left to empty I have on my 2000 Mk2 Mondeo I have left when the petrol light on my control panel comes on??? Thanks Clinton.
  7. Cheers guys, Well right hand side of my boot carpet was soaking and stinkin so I took that out and job done......doesnt seem to have water in the spare wheel bit tho so where would it come from as the side of the boot (above the right wheel) is a bit wet 3/4 down!!! Also where my lazy right foot sits above accelerater was a little wet but only a small patch and I could feel it any higher or off the panels so not sure if it was just my foot or coming from underneath. Any thoughts???
  8. Hiya guys, Last few days I am getting really bad condensation on my windscreen and the rear one and also on the other windows sometimes. Even after 30 minutes of driving with the temp setting on the warmest with the windscreen/feet option used it clear the drivers side just about but then its either steamed up on the other windows or there are droplets all on the inside. Aint gotta clue why this but it does my head in. I have tried all different setting and its not as if my air is cold cuz it does come out quite warm. I even use the two heated screens option but that tends to take ages and on the rear hardly do anything. Any ideas??? Or maybe I shouldnt be gettin the condensation in the first place??? Oh by the way my air con is empty but I dont switch that on. Thanks.
  9. Sounds like CV joint to me.....can you not get behind the wheel and see if the gaitor is ripped at the wheel end of the drive shaft, letting in water and dirt resulting in the knocking or if anything has come out gearbox end on the driveshaft??? Depending on how long its been knocking and you could just re grease and use a universal gaitor, cost you about £10 which you could prob do yaself if your a competnant guy. If it looks really bad then it will need changing. Not a massive job, about an hours labour charge.....with parts.....about £100 ish maybe. Would be worth sourcing the CV joint yourself and seeing if you can get the CV joint on its own or if it comes with the driveshaft as I cant remember. Euro parts I know are cheap and cheerful. Think max £50 with driveshaft and a few quid less without. Also you get money back if you exchange your old one too!!! Happy days. Let me know how ya get on. Clinton.
  10. Hiya guys, Just so I know, can I only open my boot by taking the key out of the ignition and pressing the button???.....my MK1 obviously had the boot pull lever with petrol flap, this however just has the petrol flap. Also what engine oil should my car have......it seems very tappety when I accelerate when warm and I thought maybe I could put a little thicker oil in the car too quiet it down but I dont know what I should be using in the first place. Unless there is another theory to the tappety sound or another remedy. Thanks Clinton. :D
  11. any ideas guys..... key in door and turn to open......alarm goes off and keeps going off.......get in car and ignition light comes on but does not start......grrrrrrr.......take a fuse out think its the larm fuse and it starts.......but not central locking!!!!
  12. cheers guys spot on!!!
  13. Hiya guys.... I have a mk2 V plate mondeo 1.6 16valve.......does anybody know how long I have and capacity or even miles to get petrol when the orange warning like comes on for petrol??? Also as I only had the car about a week now im curious with the economy for example I put 30 pound in (about 27 litres I think) and got about 175 miles before the light came on......filled up with 10 pound on about 70 miles and warning light is on now......40 pound to 250 miles is that right for a 1.6???? Thanks Clinton.