Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About FriedNewt

  • Rank

Profile Information

  • Ford Model
  1. Yes they work with the hazard switch. I have tried stapping the switch a hundred times with still no joy. I have also tried another stalk from the breakers. Ahhhh, not good fun!
  2. Hello all, I have got a MK III fiesta with the left indicator not working. Problem has come and gone for a month or so now, it has now gone completly now. Right indicates with out any problems. Left clicks 2x as fast without any lights flashing on the dash or external. I have swapped both front and back bulbs with the right hand side but still get the same problem. The 2 fuses that control the indicator are not blown. Just bought a new indicator relay today, but still same problem! I think I have said all the details that are relevant, can anybody suggest anything? About 2 weeks until MOT is due, perfect timing.
  3. Thank you for the reply. That was my best bet but the only thing is that the rear wiper does not have intermittent wipe, its just on or off. I feel a bit out of my depth here. The local auto shop does not stock these, they suggested Ford dealers. Do you think their price will be reasonable or should I just phone the scap yards?
  4. My wife has a MKIII P reg fiesta and I am having problems with the rear wiper. I have swaped the motor, the controls on the colum and checked all fuses! I checked the earth connection through the tailgate and that is good. The motor will run if you connect 12v directly to it. Could this be a relay? I thought the relay was just for the front wipers? Any ideas anybody? I have been trying to fix the car up for months and I am really stuck on this one!