AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About stephencooper

  • Rank

Profile Information

  • Ford Model
    Ford S-Max Titanium
  • UK/Ireland Location
  1. Yes it is a diesel but unsure about dual mass flywheel :(
  2. Hi there,can anyone tell me if anyone has had any probs with there clutch, my car is a S-Max 56 plate from new with 59.000 miles on the clock,3 months out of warrenty and its been confirmed my fly wheel is a gonna,so now i need a whole new clutch,i only just had a new power steering pump fitted,its bringing tears to my eyes,i feel like ive been fitted up by ford with apile of crap of a car thats constantly costing me money to repair.
  3. Hi there i have the same problem with my car and i had to have a brand new one fitted,i looked on ebay for a cheaper one but they were an extra £100 dearer than ford,just hope you have better luck.
  4. yep you were right the pump has finally gone which makes driving near impossible,ordered a new one from ford which was £100 cheaper than i could find on ebay, but it still breaks my heart as im only 4 weeks out of warrenty :(
  5. Ive just done a self diagnostic test on my Ford S-Max Titanium 56 and it came up with 4 error codes ( c 15100 ), ( c 42268 ) , (c 41568 ) , (c 42068 ),does anyone know where you can find out what they mean, other than going to Ford directly,,,:)
  6. I have had my Ford S-Max Titanium 56 from new and had many,many problems from wipers going off even with no key in,windows staying down,sensors not working,air bag malfuntion,brake bulbs always going,front lights malfuntion,boot locking for days on end.With all these problems solved i was looking forward to happy days,until this morning on the school run i got a steering malfuntion then the steering locked up,i stopped the car scratching my head,so i turned the engine off and started again with no probs,managed getting kids to school and got home with no more hiccups,does anyone have any idea as to a possible solution,,,really dont want to give car up as i love it.