Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Dave kingswood

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

About Dave kingswood

  • Rank
    Newbie

Profile Information

  • Ford Model
    Focus 1.6 Zetec hatch 2003
  1. My Focus 1.6 Titanium has a strange knocking noise when I brake The brakes do not appear to be affected. Does anyone know what this might be?
  2. Sounds like it could be the 'watchdog' problem. If the car is 2003 model there could be printed circuit board corrosion in the instrument cluster. See BBC Watchdog web page. If confirmed as 'Watchdog' problem Ford dealer should provide replacement cluster fo £99 all in inclucing cost of dianostic test and VAT.
  3. There is a well known problem with some 03 Focus instrument clusters, known as the 'Watch Dog' problem as it was featured on BBC Watch Dog programme in April 2008. It is associated with printed circuit board corrosion. I had the same problem which also caused random failure of speedo, rev counter, temp gauge and engine warning light. Ford main dealer will charge £35+VAT for diagnostic check and if confirmed to be the 'Watch Dog' problem they will fit a new cluster for £99. Beware that the £99 is all you should pay including VAT and the cost of the diagnosic check. My dealer tried to charge me £99+VAT on top of the £35+VAT, but after a long argument they settled at £99 all in. Visit the BBC Watch Dog web page for more details and a very useful Ford UK help line number. Good Luck.
  4. My Focus 1.6 Zetec intruments (speedo. rev counter, oil pressure gauge & odometer) fall to zero and recover sometimes instantly. The ingnition warning and engine lights also come on and then go out agian. It is entirely randome and not triggered by any other event. There are no other problems power is fine. Any ideas of the cause and a fix?