AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


UncleFesta

Budding Enthusiast
  • Content count

    8
  • Joined

  • Last visited

About UncleFesta

  • Rank
    Newbie

Profile Information

  • Ford Model Fiesta 1.4TDCi
  • UK/Ireland Location ---------SCOTLAND--<wbr>---------
  1. Heater Blower Resistor Unit

    Martin Thanks for that info, that's a useful starting point.
  2. Heater Blower Resistor Unit

    Hi Jamie The temperature control is mechanical but the fan blower control is definitely an electrical switch that feeds a resistor unit on settings 1 to 3, none of which work. Setting 4 bypasses the resistor unit and turns the fan on full so you always at least have that. It's the resistor unit I'm trying to find. Come on folks, surely someone out there knows where it's fitted? Dave
  3. Heater Blower Resistor Unit

    Hi Guys and Gals The heater blower on my 52 fiesta 1.4 diesel only works on setting 4 so it looks like a problem with the resistor unit. Does anyone know the location of this unit please? A picture would also be good. Thanks UF
  4. Speedo Drops To Zero

    Found the vss..... that's not designed to come out with the engine in situ is it..... Access from above is limited by the stupid routing of brake pipes that suddenly jut out into the only gap in the engine bay on that side and access from underneath is pretty restrictive too. Guess I'll be living with the speedo dropping off for a while then. Interestingly a side effect of the speedo not working is that the revs rise slightly during gearchanges..... What causes that then?
  5. Hi All

    Hi Mod Borders around Peebles.
  6. Speedo Drops To Zero

    Thanks I'll have a look there
  7. Hi All

    Hi everyone Just joined today. Got a red Fiesta 1.4TDCi on a 52 plate which just keeps on going....and going.....and going :D Usually very reliable in other words. It has developed an annoying problem with the speedo which I've explained in a post in the technical area so any help there would be great. Looking forward to chatting with all you other like minded Ford owners Cheers Dave
  8. Speedo Drops To Zero

    Hi Folks I have a Mk6? I think Fiesta 1.4TDCi on a 52 plate and it's developed an annoying habit over the past few months. The speedo drops to zero randomly. Sometimes it will pick up again after a few minutes other times it will stay at zero for ages. This means I'm not registering mileage either. Can someone tell me where the speedo is picked up from. I've looked in the Haynes book of lies and general untruths but it only shows the ubiquitous chip on the instrument cluster with no clues as to where the speedo feed comes in. I presume it comes off the gearbox somewhere and I'm guessing it's a bad connection that makes and breaks. Any good steers as to where to look would be useful. Thanks Dave