• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


madgezza

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About madgezza

  • Rank
    Newbie

Profile Information

  • Gender*
    Male
  • Ford Model
    mondeo st200
  1. Hello all i recently got an st200 mondeo and its recently started playing around, acceleration is fine and motorway driving is also fine but if your driving around town and holding a steady anything under 50 it seems to judder and keeps trying to hold back. Its got 8mm magnecore leads which are around 15k old and irodium plugs which are also around 15k old so i would of thought they would have both been ok. Every now and then the idle will change (not drastic) sometimes it will idle at around 1000 and others around 650 so im wondering if there linked. Im going to have the throtle body off and the idle valve off to give them a good clean up to see if theres any difference but has anyone else got any other sugestions? Thank you
  2. Focus Bonnet Issue

    hi eveyone i just got my first focus today a 1.8 zetec on a 2000 plate, but after getting her home i had a job getting the bonnet open and when i finally did all seemed well. i then shut it and havent been able to get into it again the key turns all the way to the left and right but does nothing. i have since managed to remove the grill (aftermarket one) to give me some more room to see what going on but i still cant. is there any way i can get this open? and has anyone else had any problems? thanks for your help