mintalkin

True Ford Enthusiast
  • Content count

    3,603
  • Joined

  • Last visited

  • Days Won

    8

mintalkin last won the day on March 24 2011

mintalkin had the most liked content!

About mintalkin

  • Rank
    Ford Enthusiast

Contact Methods

  • ICQ
    0
  • First Name
    mintalkin

Profile Information

  • Gender*
    Male
  • Ford Model
    mondeo tdci 130
  • Ford Year
    2006
  • UK/Ireland Location
    Staffordshire
  • Annual Mileage
    20,001 to 25,000
  • Contributor
    3

Recent Profile Visitors

93,027 profile views
  1. could it be a speed limiter not cruise?
  2. first i would check for any air leaks down side of the maf sensor its common for rubber pipes to split allowing extra air in, also you could try cleaning the maf sensor itself with the appropriate cleaner.
  3. I take it all the fuses has been checked
  4. if you hold the switch up to close the window then release the switch and then hold the switch in the up position again for two seconds this should reset the one touch, do the same for down for the window down.
  5. Have you checked to see what the pollen filter condition is like as a blocked filter could cause this.
  6. No problem glad to help
  7. sounds like it could be a split intercooler hose which is the large hose on the bottom of the egr valve so check this for any signs of damage or leaks.
  8. some on ebay http://www.ebay.co.uk/itm/FORD-FOCUS-MK2-GREY-RIGHT-DRIVER-OFFSIDE-DOOR-3-DOOR-2005-2008-/272161053046?hash=item3f5e101976:g:E1gAAOSwr7ZW3txp
  9. it could be the heater control valve it a common problem
  10. the switch is easy to check if your reverse lights come on when reverse is selected the switch is ok. as the power for the sensors is taken from the reverse light i would say the switch is ok.
  11. i would start by checking the wiring at the door hinge as this often gets damaged, the problem could be just a broken wire.
  12. try disconnecting the sensors one at a time and see if the constant bleep stops.if it does the sensor which is not connected could be dodgy.
  13. this is a common problem on the mondeo, there are two thermostats and the second one which is called the oil cooler thermostat plays up and causes the temp gauge issues (moving up and down when travelling) there are plenty of posts on the web and guides to changing this component which should solve the problem.
  14. When they changed the sensors do you know if they checked the wiring for damage?
  15. it could be a fuel filler neck seal you require