• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Sue3008

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About Sue3008

  • Rank
    Newbie

Profile Information

  • Ford Model
    Galaxy
  1. Starting Problems With A Ford Galaxy 1.9Tdi

    Not a silly question sometimes the obvious can be missed unfortunately not this time. Both the battery and alternator are fine. Can you think of anything else as we are really at a loss. Thanks Sue
  2. Starting Problems With A Ford Galaxy 1.9Tdi

    my husband said he had changed the temp sensor. he has also had two Diagnostic checks run both found nothing
  3. Hi, I wonder if anyone can help me I have a galaxy 1.9tdi 1997. It runs fine but have a problem starting it it is almost like I have to wind it up. We have changed 2 relays 109 and 102 (I think that was the numbers my husband said he had changed), checked all fuses, have also had new glow plugs and glow plug sensor. We have had the power checked and there is no power going to the glow plugs but there is power going to the relays. Has anyone got any suggestions as to what it could be? We are all out of ideas and don't want to change fuel pump as it is a costly job and knowing our luck won't solve the problem. Thanks Sue