AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


New Member
  • Content count

  • Joined

  • Last visited

About leviathan

  • Rank

Profile Information

  • Ford Model
    Mk3 Mondeo 200 Y Reg 1.8 Petrol
  1. Hi, New to the forum. Always fancied a mk3 mondeo so I bought one a couple of months ago. Now have an issue and really need help. First thing on a morning the car fires up perfectly and I can drive as far as I want. Once I stop the car, it wont start again! It tries to but fails. Sometimes it will start and then seconds later fritters out. If I leave it a few hours it will start again. I have checked the following: Battery - Good Ignition leads - Good Crankshaft Sensor - Good I dont know where the camshaft sensor is or the MAF sensor. If anyone has pictures that would be amazing please! Car info: 1.8 Zetec Petrol 2000 on a y reg 80,000 miles No modifications I dont think its a fuel problem becuase when it starts on a morning its a dream to start and drive. If it was the altenator I would expect the car to die as I drive it along. If it was spark plugs I would expect to see the issue all the time, most of the time at least. One other point of note: From time to time when I turn the ignition on, all the dials whip right around to the other side before returning to their home position and then to their actual current position. PLEASE help, even if just with the location of those two sensors. Thanks in advance