Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


mothergoose

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

About mothergoose

  • Rank
    Newbie
  • Birthday 08/21/1966

Contact Methods

  • ICQ
    0

Profile Information

  • Gender*
    Female
  • Ford Model
    Fiesta
  1. Yeah, I got this too, they're now in my blocked list.
  2. Hi, I need to replace the O2 lambda sensor in my car and my hubby says he'll have a go doing it himself. I've looked on http://www.gendan.co.uk/oxygen_lambda_sens...ord_Fiesta.html for the sensor, but how can I find out the engine code for my car? I've got 2004 Fiesta, 1.25 i Duratec 16v engine, but the website wants the engine code, I can't find a plate under the bonnet at the back of the engine like the manual says, there is a plate on the inside of the drivers door, but there is no code like the ones on the website eg ZH12. I would also appreciate any instructions on how to do this procedure. Thanks for any help or advice given, I am grateful :D
  3. Sounds similar to my problem, car's running a bit rough, sometimes feels as though someones got a hold of the car, then suddenly lets loose, and zoom, away I go. It only seems to happen in about 2nd or 3rd gear, never when I'm going over 30. I put my car on to an RAC diagnostics tool, and it said it was a problem with the O2 oxygen sensor, as yet I've not had it fixed because my hubby swears it's my driving
  4. I've got a Fiesta LX 1250 '04, I had it in the garage 2 weeks ago because the engine warning light was on and it was running very rough, they said it was misfiring on one of the cylinders, they put new plugs in and it's been fine, untill today that is, it felt as if it had no power and might stall, it wasn't as bad as before and the light didn't come on this time. The thing is after the last time, I bought an RAC fault code reader, it's not showing any codes, but has a freeze frame logged with code P0130, the software that came with the code reader says that it's an 'O2 sensor circuit malfunction, bank 1 sensor 1' Does anyone know exactly what this means? Any help at all will be appreciated. I've only had the dam car 2 months
  5. Hi everyone, I'm from Northumberland and have recently bought 2004 fiesta lx. (silver) My last car was a vauxhall astra, so goodbye 'vauxhall owners network', Hello 'Ford Owners Club' ;)