New Member
  • Content count

  • Joined

  • Last visited

About Dystrom

  • Rank

Profile Information

  • Ford Model
    Mondeo MK3 2.0 TDCi 130 Ghia X
  • UK/Ireland Location
  1. Hi all, any and all help greatly appreciated: I have a July 03 - Facelift model - Mondeo Ghia X TDCi 130 bhp, 65k miles I have the following: 1) Quite loud wooshing noise from the engine and loss of power - pretty sure this is the turbo pipe? 2) I get quite a lot of black smoke from exhaust - is this mainly due to probable turbo hose issue? I did have a full main dealer service about 2mths ago and they did a 'power flush' and the smoke reduced quite a bit - but still smoked more that my wifes 57reg 2.2d 150bhp civic... (even prior to loss of power) 3) I get a rubbing/light grinding noise - seemingly from the front, only just as i pull away for a matter of 2-3 seconds... 4) One of my headlight (motors?) seems to carry on whirring quite someytime after the ignition is off. 5) I get quite regular lumpy idleing... again reduced after the service but still not right... 6) Trying to change the front sidelight bulb... can upclip the grill but dont know where to go from there! 7) Every so often, and at about 30mph the accelrator/cruise control - dont know which - sticks - almot like the cruise control has automatically kicked in?! 8) Also i have read on this site these are common faults with this model: d.m.f aux belt tensioner injectors egr valve Can you tell me a bit more about what these are, whats faults will appear, and where to read more about them. Im bound to have a couple of these at least arent i? :) So not too many problems really! MANY THANKS AGAIN! Paul