Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


phillt

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About phillt

  • Rank
    Newbie

Profile Information

  • Ford Model
    focus 1.4 cl
  1. No evedent loss of coolant Changed the plugs today and started to run better not 100% will change the HT leads tomorrow see ho that goes. THANKS FOR LOOKING REGARDS PHILL
  2. My 1999 1.4 focus has been running sluggishly over the past month and I got round to look at it today. I removed the cover for the plugs and was greeted by condensation over the underside of the cover the plugs have a divider between 2 & the sensor next to plug 3. In the bottom of plugs 1&2 it is dry but in the bottom of plugs 3&4 there is what I can only describe as a mush about 3mm deep the same colour as the coolant. Q. is the sensor something to do with the cooling system and would a replacement seal rectified the mush problem and would a new set of plugs rectified the sluggish running?