Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


Tman76

Budding Enthusiast
  • Content count

    7
  • Joined

  • Last visited

About Tman76

  • Rank
    Newbie

Profile Information

  • Ford Model
    Ford Focus (2006) 1.8Ltr Zetec
  • UK/Ireland Location
    London
  1. Hi I have a 2009 2.0 TDCi - had for 1 year, glow plug light never comes on on dash, until last week with the -2C temps pretty much all of last week, on turning key the glow plug light came on for about 5-1secs then went off - this week normal temps for time of year and no sign of the glow plug lights on dashg board so seems -1C or below and the glow plug lights will come on hope thats of help
  2. no rain since last wednesday afternoon....no problem with the brakes since last wednesday afternoon Have cancelled the appointment with Ford :)
  3. After your reply i thought back and indeed for the last 3 days it has been raining day and night and the braking problem both in the morning and in the evening after work has been there - yesterday day no rain and guess what no wierd braking problem on intial brake after cold start. No rain over night and this morning...no sign of the brake problem No rain for day is forecasted so if it is still the same this evening with no problem on first brake going to call Ford and cancel the appointment for monday So when it was doing it at the low speed - as you said it seems its due to the layer of brake dust on the discs but why do the brakes come on so fierce with just a light press of the pedal? is the sensor confused or is it a design to rid the rust of the disc? Thanks Again Brian for taking time out to reply - has put my mind at rest Trevor
  4. Thanks for this Alan Even though it only happens once and its the same time each time (i.e first brake from a cold start) and then its fine for the duration of the journey?
  5. Hi Guys thanks for this - I called ford yesterday to book it in for this coming monday - when i mentioned what i am experiencing he did mention that fords seem to suffer from this type of problem when the autumn arrives and the weather becomes more damp and wet - he did say more or less what you guys are saying "on first use they may well do this - once the rust has been removed from first braking, the brakes will return to normal" So ive had this issue for the last 3 days during which there has been plenty of rain. From first start in the morning it exhibits this problem. When I use it in the evening approx 8 hours later it does it again. Ive checked in the evening to see if i can see a coating of rust on the discs but cant seem to see any. Does it still sound like what you guys have mentioned? Thanks
  6. no warning lights on the dash. will check the brake fluid resevoir tonight al though it was in at ford in June for brake fluid change. have pumped the brake pedal with car off and the brake pedal stiffens up so seems the servo unit is ok? only happens on the first braking from a cold start so will hard for them to replicate the problem. tonight going to switch on ignition drive a bit and brake then switch off engine. switch it back on and drive a bit and see if it occurs again - hopefully it will then i can take it to ford and tell them how to find the problem - if there is one - strange it doesnt do it all the time just the very first braking?
  7. Hi Guys I have a 2006 Ford Focus 1.8Ltr Petrol which over the last few days has (i think) started to develop a braking problem... From a cold start on pressing down on the brake pedal the first time after moving off from cold start the car seems to brake harder than the amount of pressure I have applied to the pedal. After this first braking all other braking is as would be expected. To try and give an example I start the car from cold - approx 10 mtrs down my road i need to stop to turn right - get the car up to around 10mph before i need to brake for the first time- the car kinda slightly lurches forward on pressing the brake pedal ( not dangerously) just enough to draw my attention to the braking? After that I have about a 20min drive during which braking is fine? Help/Advice greatly appreciated - I have a 2 yr daughter in the car with me so concernded whether this is a problem or me being paranoid