• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


typhoon5989

Budding Enthusiast
  • Content count

    10
  • Joined

  • Last visited

About typhoon5989

  • Rank
    Member

Profile Information

  • Ford Model
    Escort Freedom 1.4 4dr
  1. Door seals

    This Colin Ford guy sounds like a bit of an !Removed! hole if you ask me. If you wanna !Removed! fords, then do it in a vauxhall club.... !Removed!!
  2. Another new car

    Looks excellent for £200. Screaming out to be modified! Let me know how you get on.
  3. escort mk5 fuel problem

    I had the very same problem with mine when i first bought it. A couple of shopping trips would empty my tank. I gave it a mini service myself (Cost about £35 for everything). New spark plugs, air filter, Oil filter and oil change. I also changed the fuel filter, but i don't think that will be necasary. I also took off all my breather hoses and gave them a thorough cleaning. Might sound trivial, but I did it anyway to be safe. Hope this helps.
  4. Horn Not Working

    Help!!! I know it's not the most important thing in the world... But does anyone know how to fix my horn? I've taken off the central part of the steering wheel and thoroughly checked all of the horn connections. Is there any way to check the horn operation with different wiring and a different power source or is there something I might be missing?? By the way, it's an escort Freedom 1.4 mk7.
  5. Reverse Lights Not Working

    Hi I have a mk7 escort and recently, my reverse lights packed in. I've checked my bulbs and fuses but no luck. :-( I've looked in a haynes manual and it states that there is a sensor (kinda looks like a lamda sensor) located somewhere around the engine. Has anyone had this problem before and how easy was it to fix? Got the answer email: typhoon5989@yahoo.com I'll be happy to hear from you.
  6. Dashboard Respraying

    Hi, i've got a mk7 escort freedom 1.4. I've just started on the road to improving how my interior looks. I've decided to remove the entire dashboard and respray it, but what i need to know before i start, is how easy is it to remove in the first place? Does anything else need to come out before the dashboard is touched?
  7. veggie oil in diesel tank?

    My dad uses chip fat oil in his 4x4. Has done for years. He says it runs like a dream, and a hell of a lot cheaper too! GOAL!!!!
  8. Hi, i've got a mk7 escort freedom 1.4. I've just started on the road to improving how my interior looks. I've decided to remove the entire dashboard and respray it, but what i need to know before i start, is how easy is it to remove in the first place? Does anything else need to come out before the dashboard is touched?
  9. Horn not working

    Help!!! I know it's not the most important thing in the world... But does anyone know how to fix my horn? I've taken off the central part of the steering wheel and thoroughly checked all of the horn connections. Is there any way to check the horn operation with different wiring and a different power source or is there something I might be missing?? By the way, it's an escort Freedom 1.4 mk7.
  10. Reverse Lights not working

    Hi I have a mk7 escort and recently, my reverse lights packed in. I've checked my bulbs and fuses but no luck. :-( I've looked in a haynes manual and it states that there is a sensor (kinda looks like a lamda sensor) located somewhere around the engine. Has anyone had this problem before and how easy was it to fix? Got the answer email: typhoon5989@yahoo.com I'll be happy to hear from you.