AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


greggp

Budding Enthusiast
  • Content count

    283
  • Joined

  • Last visited

About greggp

  • Rank
    Feet Under The Table

Profile Information

  • Gender*
    Male
  • Ford Model
    Focus 2008 1.8 petrol Titanium
  • Ford Year
    2008
  • UK/Ireland Location
    Essex
  • Annual Mileage
    0 to 5000
  • Interests
    General Automotive
    Car Modification
    Entertainment
    Computers & Electronics
    Sports & Leisure
  1. Possibly a failing battery. I had a few random dash messages pop up last month or so, and then the cold weather came and last night my battery failed on me. All fixed now
  2. Battery wasnt holding charge. AA new battery fitted,all seems ok started her over a few times. Only weird thing being the outside temp still saying -59 deg c and when trying to re program clock it wouldn't go past the year 2013. Weird ?? 🤔
  3. Headlights working and all interior lighting works, dash lights up. Tried electric windows and were a bit slow closing. Tried starting again and strange clicking when trying to start her but just not turning over at all. Ran dash trick mode. Battery level says 10.8v. Then found all these dtc Dtc 900 Dtc e510 Dtc 5759 Hopefully just a battery issue as have had heated screens and air con in the recent weather spell. Looks like a trip for the AA
  4. Thought it struggled to start this morming tbh. Managed to drive home but just went to pop out... And wont start, not turning over at all. All kinds of crazy messages on display, "power steering malfunction", "transmission failure", outside temp says -60 deg c!!! Could this be battery or alternator possibly, gonna go and put it in diagnostics mode shortly and see if that sheds any light Any help appreciated. Cheers
  5. Thanks. Yeah will keep an eye on it.
  6. Yeah just tried it under load as you suggested and the voltage dropped to 11.6v at lowest. Fluctuated between this and 12v whilst under a full load. Load used at same time as below:- Heated front & rear screens Front headlamps full beam Front & rear fogs All interior lighting Air conditioning on full Front Wipers on max
  7. Done the dash trick. Battery is 11.8v without engine running, 13.8v with engine running. Scrolling thru menu I did find this DTC #01 D900 Not sure if this is a fault code of somekind and/or related to yesterday?
  8. Got in car today, turned ignition and got the audio chime (when fuel is low) followed by dash warning "power steering malfunction" message . Turned ignition off and on and no warnings this time? I note from the manual that the 1.8 duratec petrol says no checks are required to power steering levels....so I'm guessing its electric system? Drove fine to and from work no issues. Maybe a computer glitch? Will keep an eye on it. Model 2008 facelift 1.8 duratec petrol titanium
  9. Noticed my coolant tank was very low earlier so topped it. But have now found the cause. Is this just a case of a new hose needed? Cheers
  10. OMG!😱
  11. okay thanks - I thought possibly something like that....panic over :)
  12. sorry - it didn't upload for some reason. should be there now :-)
  13. Hi All, Had bonnet up to check my oil level earlier, and noticed this hose not connected to anything?? anyone know what this is and if it should be connected to anything please? Not sure where this goes to, appears to go up towards the windscreen area? picture attached :-)
  14. Throttle body! Had exactly same issues. Never again since replacing. Not cheap fix mind.
  15. Thats correct jbeer! assuming you mean the instrument cluster being lit?? Its a backlit dash like all newish cars these days, doesnt matter if sidelights)headlights are activated or not the speedo and rev cluster is always back lit