Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About percypond

  • Rank

Profile Information

  • Ford Model
    2000 Fiesta Finesse 1.3
  1. Since i last wrote ive had a major issue where it had to be towed thanks to a core plug failing and a major water leak. Luckily that side is fixed now and i've been back on the road since today. However the speedo is now completey dead. It wont even work if i hit it (it did before) and also now its stopped counting the mileage. I read somewhere that the speedos on fiestas from 2000 onwards are linked with the gearbox. When my core plug was replaced to get to the one that had gone the gearbox had to be taken out. Its since then its been gone altogether. Any more ideas? Thanks for the help again ;)
  2. whats the sender? sorry blonde question probably i know, and what type of wiring fault i'm at least trying to have some knowledge of whats wrong before it goes to a garage so im not ripped off. thanks for the help again :-)
  3. Hello i have just bought my first car a 1.3 ford fiesta finesse 2000. Its done aprox 47,000 miles. Everything seems fine with the car (except one thing) and on the test drive everything was ok. However on the way home from picking it up i've noticed there is a fault with the speedo. Sometimes it sits at zero and othertimes it jumps into action. Because im a new driver who lives right down a road with about 11 speed camera(traps) i need to sort it pretty quick so i dont get any points!!! When it does work it seems to be accurate its just it doesnt work all the time and sits at zero. Anyone know what could be wrong, if its a big job and how much i'm gunna be looking at spending? Thanks for anyone that helps me out. Louise