AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


dandan_00000

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About dandan_00000

  • Rank
    Newbie
  • Birthday 06/22/1984

Contact Methods

  • ICQ 0

Profile Information

  • Gender* Male
  • Ford Model escort mk6 1.8 16v si
  1. out of ideas!!

    CHEERS MATE HOW WOULD I RESET THE ECU???? ANY OTHER SUGGESTIONS WOULD BE GREAT ;)
  2. out of ideas!!

    Yer had a slight problem with that when reffitting the head but we sorted that. thanks for the suggestion any other thoughts would be greatly received.
  3. out of ideas!!

    Hi i am new to the forums and am looking for some help. I have a 1.8 16v zetec escort i've just had a ported polished head done as i was supisciouse of a dodgy valve. turned out valves were good but slightly warped head. Anyway i'm still having runnig issues. when i start the car it idles ok but gets a biot jumpy whilst idling on accelaration its stuters under 2k revs then finds the power. Then at 4k in fifth it stops pulling and just sits no gain in revs or gain in speed. I have also changed the coil pack and the plugs and leads have done no more than 5000 miles. Mid range there is power and it seems to improve when its warmed slightly I can't accelerate quickly as it just splutters. Any help greatly received.