Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


MrRedman

Budding Enthusiast
  • Content count

    168
  • Joined

  • Last visited

About MrRedman

  • Rank
    Feet Under The Table

Contact Methods

  • First Name
    Paul

Profile Information

  • Gender*
    Male
  • Ford Model
    focus 2.0 Ghia Duratec Hatchback
  • Ford Year
    2005
  • UK/Ireland Location
    Lancashire
  • Annual Mileage
    0 to 5000

Previous Fields

  • Location
    Manchester

Recent Profile Visitors

3,364 profile views
  1. I had uneven idle on a mk1 1.6 petrol I took the idle control valve off and cleaned it out with carb cleaner it's located at the front 2 bolts hold it on and it has a wire connector was fine afterwards Google the part so you can identify it if your not sure worth a go 👍
  2. I bought some from eBay the markings are there but smaller than most!
  3. Ok this works remove the light in the roof under where the aerial is fixed undo the bolt which fixes the aerial and fix under it some copper wire(I used solder type wire ) any will work.next undo the earth bolt for the light next to it and put the other end of the copper wire under that fasten the bolts back up tight put your light back and hey presto the reception on am is miles better!
  4. As for the air bag my light came on briefly it turns out there are connections under seats which in my case was knocked moving the drivers seat back and forth,have a fiddle n press them tight ! Think somebody had said do this after the engine has been stopped for at least half an hour
  5. Ford adjusted the gap apparently from 1.3mm to 1mm when I've bought plugs over the last 5 years or so the gap has always been correct so I'm guessing you'll be able to put them straight in
  6. Yeah that's them with the bigger seal round just take it steady with the plugs they may be stuck firm use something to free them up first WD40 to soak in for a while once the water is clear and you dry the plug leads with the dryer it will probably run as normal
  7. We eventually cleared ours by getting the revised washer jets from Ford that's how the water gets in use kitchen towel to get it out then finish with the hair dryer worked for me ! Good Luck
  8. If it's a petrol 1.6 check for water in the plug ports
  9. My parking sensors started to bleep all the time whilst reversing I've cured it by cleaning the sensors with wd40 on a cloth thought you lot might want to know for future reference !
  10. I left the riveted part in and just cut away the speaker cone I bought some 6.5inch speakers from eBay and screwed them straight into the riveted surround of the old speaker works fine.Door panel slightly tighter when pressed on that's it
  11. This light came on briefly on start up on mine last night but I haven't broke down yet,I'll be interested to see what everybody thinks
  12. I just cut out the middles of the blown rear speakers leaving the plastic in place and screwed the new ones from ebay directly on to the plastic.The door card was just a little tighter to press back on but no rattles or vibration!
  13. Check your wheel nuts 1st
  14. Nice motor good luck with the test I passed many moons ago age 17 and 1 month and yes I had 2 crashes in the 1st 18 months so simcor has a point. my advice don't have the radio on for a month to begin with Crapital will only distract you ! 😂😂
  15. My alternator failed a few weeks after having a similar sound which disappeared by the time I'd drove to work !