Ford Owners Club - Ford Forums Messages

FORD FAIR – SILVERSTONE – 6TH AUGUST 2017

Join us on the Ford Owners Club stand at Ford Fair, Silverstone on Sunday 6th August 2017.

Click this link to find out more



MrRedman

Budding Enthusiast
  • Content count

    240
  • Joined

  • Last visited

About MrRedman

  • Rank
    Feet Under The Table

Contact Methods

  • First Name
    Paul

Profile Information

  • Gender*
    Male
  • Ford Model
    focus 2.0 Ghia Duratec Hatchback
  • Ford Year
    2005
  • UK/Ireland Location
    Lancashire
  • Annual Mileage
    0 to 5000

Previous Fields

  • Location
    Manchester

Recent Profile Visitors

3,966 profile views
  1. Maybe I'm barking up the wrong tree here but I've just fitted dab in my car and it seems dab signals need power to the aerial for it to work fm does not wondering if it's the power to the aerial which is down ? Maybe another fuse possibly on the back of the unit ? Just a thought
  2. Hi mate no not yet I'll look Tuesday when I'm off , I was hoping there would be a genius plug expert on line this weekend haha 😂
  3. Ha sorry for the confusion the last picture is in the passenger side of the car the last one is twice the size
  4. Here's the other 😂
  5. Hi upto now I can't see anything it's a bit dark n awkward round there too. ive found another one now bigger on the left side of the centre console towards the front must be for something that's optional I'll get a picture later 😂
  6. Hi I've bought a single din Sony DAB car radio ,so I've bought the kit to reduce the opening off eBay Apart from it not sitting quite right/flush the clips the supplied well 2 have pinged off god knows where My question is how could I fix it without these useless clips ? I realise now the stalk control won't work as the must be another part to the kit which isn't included can I buy these in Halfords? cheers
  7. I'll have another look and check it's not for lighting around the pedals ? doesnt look as if it carries much current by the thickness of it
  8. Bump
  9. So I'm messing around like you do and I've spotted this plug hanging down behind the clutch pedal any ideas what it is ?
  10. Used to think this was a good idea but I reckon swapping the fronts as and when they wear down is better ,you don't want tyres that are really old on the front in case of a blow out they are probably better on the back ! Agree?
  11. I've a 2.0 petrol and mine is the same it's not gone any worse tho
  12. The clicking is correct it's likely to be a break in the feed to the motor just where it bends at the roof it's happened twice to me there
  13. I had this problem I sawn the head off with a hacksaw blade then drilled new holes in the boot to take self tappers 👍
  14. I always check the oil with the filler lid off so no oil is trapped higher up i.e. No Vaccum if that makes sense as I thought there could be false readings so you would over fill and it would burn off ? Just a thought
  15. I'd guess the permanent live fuse has blown so settings are not backed up not sure if it's inline behind the radio or in the fuse box tho ? Worth a look