AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


MrRedman

Budding Enthusiast
  • Content count

    178
  • Joined

  • Last visited

About MrRedman

  • Rank
    Feet Under The Table

Contact Methods

  • First Name
    Paul

Profile Information

  • Gender*
    Male
  • Ford Model
    focus 2.0 Ghia Duratec Hatchback
  • Ford Year
    2005
  • UK/Ireland Location
    Lancashire
  • Annual Mileage
    0 to 5000

Previous Fields

  • Location
    Manchester

Recent Profile Visitors

3,445 profile views
  1. Hi I had this problem I solved it by releasing the overhead light under the aerial once done undo the bolt holding the aerial and slip some copper wire or simular underneath re tighten, on the other end (wire approximately 5 inches long) put it under the earth bolt for the light this will work just make sure connections are good
  2. Did the battery thing no difference the yellow light and warning sign still there ?!!
  3. No I was thinking I'll do it tomorrow
  4. Anybody had this problem ? Would disconnecting the battery help?
  5. Yes the garage did but it's not gone away they said it may go away when it detects the new pump or I'll have to come back
  6. Hi everyone so I've had a new power steering pump fitted and the message hasn't cleared on the display the garage said it may go on its own once the computer recognises the new pump anyone had experience of this ? Will it go on its own or will they have to try again? Cheers
  7. Hi did the car learn its self or did it need Ford Dealer intervention ? I have the same issue myself after having a new pump.
  8. We have a 1.6 as well with I guess the original cluch on 69K I've the 2.0 and it's quite fast it's the 1st 2.0 I've ever had haha,fuel readings on the onboard computer are about the same!
  9. Brakes aren't binding on are they?
  10. I had uneven idle on a mk1 1.6 petrol I took the idle control valve off and cleaned it out with carb cleaner it's located at the front 2 bolts hold it on and it has a wire connector was fine afterwards Google the part so you can identify it if your not sure worth a go 👍
  11. I bought some from eBay the markings are there but smaller than most!
  12. Ok this works remove the light in the roof under where the aerial is fixed undo the bolt which fixes the aerial and fix under it some copper wire(I used solder type wire ) any will work.next undo the earth bolt for the light next to it and put the other end of the copper wire under that fasten the bolts back up tight put your light back and hey presto the reception on am is miles better!
  13. As for the air bag my light came on briefly it turns out there are connections under seats which in my case was knocked moving the drivers seat back and forth,have a fiddle n press them tight ! Think somebody had said do this after the engine has been stopped for at least half an hour
  14. Ford adjusted the gap apparently from 1.3mm to 1mm when I've bought plugs over the last 5 years or so the gap has always been correct so I'm guessing you'll be able to put them straight in