• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


davell

New Member
  • Content count

    1
  • Joined

  • Last visited

About davell

  • Rank
    Newbie

Profile Information

  • Ford Model
    galaxy 2L tdci 140 6G
  1. hi thanks for looking and hope you can help. i have a 56 plate new shape galaxy 2.0 tdci 140. firstly i'd like to be sure that whether the injectors are coded on these models. it has starting problems. once started there is no power and it dies away and sometimes cuts out after a few seconds. if i am able to hold the revs for a short while it soon dies away once i try to pull away. I have removed all injectors and replaced copper washers. I have a small compression leak through the left hand side (no 1 cylinder i think) injector but not enough to cause the power loss. I'm wondering whether its a fuel pressure problem and if so is this more likely to be the fuel pump or maybe a failing regulator/solenoid. Is the reg/solenoid fitted to the common rail. Maybe someone has had the same problem and can offer advice, all of which would be greatly appreciated. I have owned the car from new and its been a great workhorse, its covered almost 170,000 miles. look forward to hearing from anyone. Thanks Dave