Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


theglad

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About theglad

  • Rank
    Newbie

Profile Information

  • Ford Model
    fiesta
  1. i changed the stalk cos i broke the indicator side just the plastic which connected it to the rest of the unit all the electrical components were working fine before i changed them over
  2. the stalk has been correctly fitted and now when the old stalk is refitted it still doesn't work. i checked the fuses by the steering wheel and none seem to have blown what i'll do is buy a job lot of fuses and change the lot as i haven't a clue which one is for the wipers i'll also take the new unit off and make sure the connections are kosher and i'll let you know how things work out
  3. hey all i'm new to the forum so be gentle lol this morning i changed my indicator/wiper stalk on my mk5 fiesta and since the change my wipers don't work. they stuttered when i changed the stalk over but now they don't work at all even when i put the old stalk back on it made no difference. looking over the fuses i can't see any which have blown so i'm hoping it's not the motor packed in. has anybody else had any similar problems? all the best Jamie