AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


focus87

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About focus87

  • Rank
    Newbie
  • Birthday 09/10/1987

Profile Information

  • Gender* Male
  • Ford Model 2008 Focus Zetec 1.6 Petrol
  1. Hi all, hope someone can help, When I use the key fob to operate the central locking on my Focus, I have to use it stood right next to the driver or passenger doors when I move away from these areas (even stood infront of the car)nothing happens. Changed the Battery twice and cleaned the contacts with alcohol wipes but still does the same. Find this very frustrating as it defeats the object of having remote central locking. Car is a 2008 Ford Focus Zetec petrol.
  2. Hi, can anyone tell me the location of the fuel filter on a 2007 1.6 duretec focus zetec. Dealer said its changed every 60,000, or around 6 years, this seems a long time?
  3. Focus Hesition/misfire On Motorway

    My dealership mentioned the brake fluid at 2 years but never mentiond the power steering fluid? also what about the gearbox oil?
  4. Focus Hesition/misfire On Motorway

    Thanks for the info guys, car is in tommorrow and ill bring up those to potential items. At what intervals are the fluids chaged? Power steering, coolant, brake fluid.
  5. Focus Hesition/misfire On Motorway

    Just to update, the car is petrol. I was thinking the fuel filter and also heard about HT leads and coil packs although would these really need replacing at this age and mileage? Car idles fine, isnt using excessive fuel and is fine under heavey acceleration and normal acceleration around town. Thanks for the quick replys guys
  6. Hi, new to the site today. I have a problem with my 3 year old 1.6 duratec focus zetec with 35,000 miles on the clock. When i am on the motorway I will be cruising along at a steady 65mph and radomly feel the engine miss a beat/hesitate. This happens for a second and no warning lights. It only happens at 60-65 mph (around 3000 rpm). I use the motorway twice a day to commute to work, 14 miles each way. It has happend around 3 times in the past 4 months. Car is fine when accelerating and above/below this speed. On my last service with Ford in august they changed the spark plugs and this did seem to help but problem has returned. Hope someone can throw some suggestions. Thanks, Steve