Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About Roukel01

  • Rank
  • Birthday 08/21/1979

Profile Information

  • Gender*
  • Ford Model
    Granada Scorpio
  1. Hi, thanks for the help. Yes I checked all fuses that I could find (behind the glove box and under the bonnet) When you say check relays,. what can I do with them, and which one is it that works lighting etc? Thanks
  2. I'm sure the earth is fine. Like I said earlier in my post, what really confuses me is the fact that as soon as I tempereraly connected the failing tail light to the working one, both did not work. I have since put the wiring back as it was, and now the one working tail light does not work. Plus, wouldn't a bad earth affect other lights in the cluster? As all other lighting is working as it should.
  3. Thanks for the reply, no I checked power at the connector also.
  4. Hello All I have a 2003 Mondeo. The drivers side tail light has stopped working. Checked bulb, that was ok. I swapped anyway just incase, but it still isn't working. I checked with my test lead and there's no power to the lamp holder. All other lights are working, breaks, passenger tail light, front lights etc. Checked all fuses in both boxes and all were ok. So, I ran a temporary lead from the working tail light to try and get it going, but that took the working one out too! Checked all fuses again, but still all OK. Where do I go from here? Any suggestions would be appreciated. Is there some kind of computer controlled safety overload that might have kicked in? if so, how do you go about resetting it? Many Thanks for any help. Lee
  5. Hello everyone I bought a '93 Granada Scorpio not too long ago. You don't see many about these days and I wondered if anyone knows how many are left in the uk? Thanks Lee
  6. 102_6464.JPG

    From the album My Car!

  7. 102_6440.JPG

    From the album My Car!

  8. 102_6438.JPG

    From the album My Car!

  9. Hello All I have a 1993 Scorpio 2.0 Auto. I noticed that the interior lights were no longer working, and the same with the central locking. One night when driving home (obviously with my lights on) I nuged the door lever with my elbow and the Central locking worked perfectly! as did the interior lights. I got home, switched the car lights off and both the central locking and interior lights no longer worked again. It seems that both these will only work when the lights are switched on! I had a look through my Haynes manual and found that all three of these systems seem to share a common Earth connection, and so my first guess would be that this connection is corroded or something. the trouble is, I have no idea where I will find this earth connection to check. Can anyone point me in the right direction, or give me any other advice on what I should check? Thanks.