• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Dr A

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About Dr A

  • Rank
    Newbie
  • Birthday 01/17/1987

Profile Information

  • Gender*
    Male
  • Ford Model
    Fiesta

Previous Fields

  • Location
    Reading UK
  1. Right gasket is now changed does look like that was where the leak came from. New HT leads on but still engine light on. Got a feeling that the oxygen sensor might be dirty from the oil that got in to the engine when I changed the plugs. Ive also herd that the coil pack gives the same symptoms to what im suffering from. Is there any way I can find out the engine codes? For example some sequence of turning the ignition on with buttons pressed. hope someone can help. Cheers guys
  2. Hi Guys Thanks for spending the time to reply God bless you. The car had been in the garage over Christmas getting its crank shaft shells replaced and whilst it was sat there I think rain water had leaked in via the washer jets as when I got it back it was misfiring like crazy. So I took the HT leads out to find all the spark plugs underwater. Screw driver with tissue paper and new spark plugs later it was all dry so I put it back together and hey presto the car was running smooth and engine light had gone away. A week later light comes on again and this time its oil round the plugs. Removed oil same way as water and cleaned plugs with WD40 put back together and engine light is still on. So as you have kindly stated im going to replace the gasket tomorrow and put new HT leads on and hopefully it will not leak and performance will come back with no !Removed! yellow light lol Have noticed that the coil pack makes a hissing sound when engine is running hope I dont have to change that. Thanks again ill keep you updated! Adam
  3. Hi all My fiesta Mk6 1.4 Zetec has been running rough and sometimes miss firing during low revs. Took the HT leads out to find they were covered in engine oil and the two spark plugs to the left were sitting in a puddle of oil. Im guessing the rocker cover gasket has perished and the oil is causing the engine light to come on. Is there any other things that could leak oil in to the spark plug bay? Core plugs maybe? Any way hope you could add some insight in to this Cheers guys Adam