Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About stevebr

  • Rank
    Settling In Well

Contact Methods

  • First Name

Profile Information

  • Gender*
  • Ford Model
    Focus 1.6LX Estate
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    0 to 5000
  • Interests
    Classic Cars
    General Automotive
    Car Restoration
  1. Thanks all, It is the pump that is gone. Having a new one fitted on Monday-only prob pump is now totally gone so will have to drive the car to the garage without power steering. Will give it a go tomorrow. Regards Steve
  2. Thanks! Someone mentioned that the old pipes need to be cut off-but every time I've changed pumps/pipes they just unscrew. I'm sure the pipes do not have to be replaced when a pump is changed. Is this right? Thanks again Steve
  3. Hello all, I've got another leak on my 2005 1.6 Focus. I had one three years ago and the pipes were replaced-it now looks like the pump is leaking. Any ides where to get a cheapish pump? I've had a quick look at ebay and they are around £200 Thanks Steve
  4. Many thanks yet again! Regards Stev
  5. Thanks! Will try and find an estate version! Regards Steve
  6. Hello all, I have a 2005 Mk 2 estate with a damaged drivers door. Will a door from a hatchback fit? I have seen a few on ebay-but all for sallons-they look the same-but any advice would be appreciated. Thanks Steve
  7. I got a calcium from Halfrauds for £50 with a three year guarantee-needed it then and there./ steve
  8. Many thanks yet again. Will get it done in the New Year. Thanks Steve
  9. Hello all, Have had a look but cannot find the answer! Wife has a 55 plate 100hp 1.6 petrol. It has done 55000miles. At what point does the timing belt need replacing on these? My old Omega's were 50000 miles. Any help would be greatly appreciated. Many thanks Steve
  10. Just a quick update. Wife kept saying there was nothing wrong with her car-it must be me imagining things. Then it refused to start for her outside the son's school-ha! ha! Put a new battery on and has been fine. many thanks Stevve
  11. Many thanks for both answers. I will get a new battery and keep you posted. Regards Steve
  12. Evening all, I have a 55 plate 1.6 100bhp estate. Recently when starting it struggles to turn over and I can see a front light coming on from inside the car. The car then starts. It will start no problem a few times and then this problem reoccurs. I suspect the battery, but have never had one behave like this before-perhaps it is a feature of the calcim battery. Any thoughts before I buy a battery will be greatly appreciated. Thanks Steve
  13. Thanks, Have found that Thule sell flat headed bolts to slide into the track to overcome the problem. £3 each so I still think I will drill and use the nuts and bolts I have in my garage. Cheers Steve
  14. Morning all, Recently bought a set of genuine Ford roofbars of ebay for my 2005 Focus Estate. Tried fitting my Thule Cycle Carrier but the brackets that go around the bar are too small. Looks like I'm going to have to drill and bolt the carrier on. Keeps me occupied! Steve
  15. Changed the bulb this morning - took 5 mins and very easy. Many thanks again James! Steve