• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


foxee

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About foxee

  • Rank
    Newbie

Profile Information

  • Ford Model
    Focus 1.6 TDCI
  • UK/Ireland Location
    ---------Ireland-----------
  1. Focus Indicator Lamp Problem

    Yea I tried a new bulb,the old one was fine but I changed it anyways, checked the connection at the base of the bulb and the fuses too.. I didnt seem to fix it but then we got a week of good dry weather.. probably 13c, it started working again. The only thing that I could put it down too was that a wire somewhere was damp...
  2. Hey all.. Have a problem with my 05 focus… When I turn on the indicator to turn left the bulbs on the front and side light but not the rear… I have checked the bulb and connections but all seems ok… the fuses seem good also.. The ticking noise that is made when the indicator is on to the left is fast.. When the right is on the ticking sound is normal.. Hope all of that has made sense… :o