• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Swiss_Saint

New Member
  • Content count

    1
  • Joined

  • Last visited

About Swiss_Saint

  • Rank
    Newbie

Profile Information

  • Ford Model
    Focus Ghia 1.8 tdi estate
  1. I have an 04 focus Ghia 1.8tdi estate and it has been pretty reliable since I got it 3 years ago. I recently had the clutch replaced and all was fine but now about 3/4 weeks later the engine management light has come on. I got it diagnosed and it brought up 3 turbo related issues however I have suffered no loss of power. Question is could the new clutch and the EM light be connected somehow as the car is running fine even though my mechanic is scratching his head as according to the codes I should have no or limited power!!!. First time it came on he checked the car over and could not find anything so reset the light. I then drove around 400 miles (scotland and back as well as liverpool - manchester a number of times) with no issues. Light came on again last night so it is going in again but again no loss of power. Any bright ideas folks? SS