Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


KJO

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

About KJO

  • Rank
    Newbie

Profile Information

  • Ford Model Fiesta
  • UK/Ireland Location ---------Ireland-----------
  1. I have a 97 1.3 Fiesta with an endura engine. All through the summer I was getting 54 mpg. However now winter has come the consumption has fallen to 40 mpg. Is it usual for the winter consumption to fall so drastically The journeys are just the same, a 20 mile commute which is mainly rural driving. Any suggestions as to why the fuel consumption has fallen so much?
  2. Steering Rack

    I require a nylon bush for the steering rack on my 97 1.3 petrol Fiesta. Please note It is not power steering. If anyone has such a part would they please make contact by email to kevin.orde@gmail.com. Many thanks.
  3. Engine Misfire

    Sorry I forgot to mention that it had the master cylinder replaced. There was no misfire before that. The model is a 1997 1.3 Encore.
  4. Engine Misfire

    Surely if the HT leads or coil pack were giving trouble it would show up on a diagnostics test?
  5. Engine Misfire

    After about 2 miles it starts to misfire. This can be cleared briefly by depressing the clutch but then the misfire will return after a minute or so. The misfire also clears if when moving the ignition is turned off & on again & will not return so long as the car is cruising at a constant speed. The misfire returns upon accelerating after the gears have been changed down. The air flow meter has been replaced as well as the clutch switch. Its been checked on diagnostics & no fault showed up. Anyone any ideas.