• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


holfster

New Member
  • Content count

    1
  • Joined

  • Last visited

About holfster

  • Rank
    Newbie

Profile Information

  • Ford Model
    s max
  1. hi, my engine management fault light came on and it went into limpb mode (under standable) and then went off when it was re-started this happenend a couple of times but it seemed to be ok when the fault light went off ,i only started to think something was wrong when driving up an incline at 2000rpm it seemed to miss fire but after 2000rpm it seem to pass. this together with my mpg falling to 32mpg is when i took it to the garage and the errors where stored as turbo boost pressure low this fault has been cleared from the ecu so ive just filled up with bp ultimate £95(wth)and im waiting to see if it happens again.any help on this and i would be greatful ,,,thanks