marrak1967

Budding Enthusiast
  • Content count

    22
  • Joined

  • Last visited

About marrak1967

  • Rank
    Member

Profile Information

  • Ford Model
    ford mondeo zetec 2006
  1. Hi guys still having problems with car i have bought haynes manuel and it says if rear sender unit is not working there is a problem with pcm ,powertrain control module and needs go to ford garage to sort.Is this a big job and what does it involve.MANY THANKS TO ALL FOR YOUR PREVIOUS HELP.
  2. YES MATE THEY ARE NEW ASWELL.WHEN I TURN IGNITION ON I DONT SEAM TO HEAR ANY NOISES FROM THE SENDER UNIT.IM SURE YOU USED TO HEAR IT TURNING ON AND WORKING.SO I THINK ITS GETTING STAVED OF FUEL.ANYBODY KNOW WHICH FUSE IT IS FOR THE SENDER UNIT AS I DONT HAVE MANUAL.THANKS
  3. HELP.MY MONDEO IS NOW NOT STARTING.i have changed battery and its had full service i had reply to my previous post saying it could be either the cam shaft sensor or crank sensor so i decided to replace both but still not starting i loosened each injector to see if fuel was getting through it was on all 4 injectors.i have had egr valve off and it has been cleaned.i just dont know whats the problem.any suggestions much app,thanks michael
  4. Update as usual mondeo would not start so checked out the forum and some people suggested that either the camshaft sensor or the crankshaft sensor so today i changed both and car is still struggling to start.anybody got any other ideas i have pulled out the rest of my hair out.many thanks now baldy michael.
  5. checked egr valve and cleaned still the pig would not start but after i jumped it from other car it fired up.took it for a drive still smokie thought i heard a little rattle from engine this is new.when driving it still feels plenty of power.when it would not start the eng/mang/light was on and then flashing glow plug.the egr valve seamed free. but dont know if the valve is meant to be fully open or in closed postion when i checked it as i can push the valve up ?.any help much app,michael.
  6. ok mate will check this thanks.
  7. Hi there i have seviced my 06 tdci mondeo zetec and now noticed that it was starting to take longer to start in the morning so i thought it was the battery but no it still struggled to start even after new battery.I did notice that there was some black smoke when driving but today it would not start at all.any thoughts super techs.i spent alot of money getting it back on the road as it was damaged and dont want to spend loads more.many thanks michael
  8. Thanks mate radio code worked a treat.where is the pcv valve located,is it on that pipe that goes to airbox.cheers michael
  9. Ok sorry will watch that.
  10. THANKS MATE WILL HAVE A GO LATER.CHEERS.
  11. Thanks mate is that the repair kit code or radio code.Will let my brother know and try and get this sorted for him.
  12. HI TO ALL THE SUPER TECHS,MY BROTHERS CAR 2002 focus 1.6 zetec IS LEAKING OIL FROM THE PIPE GOING INTO THE AIRBOX HE THOUGHT IT WAS FROM GEARBOX BUT I LOOKED AT IT TONIGHT AND IT SEEMS TO BE FROM AIR BOX PIPE AT THE BOTTOM AND OIL LOOKS A LITTLE GUNKED UP?.ALSO HIS CAR HAD BATTERY CHANGE AND LOST RADIO CODE SERIAL NUMBER IS M368154.RADIO IS 6000CD MODEL.ANY HELP PLEASE.MICHAEL
  13. THANKS MATE WILL GIVE IT A GO CHEERS.MICHAEL
  14. HI SUPER TECHS PUT GARAGE FOR SOME WORK AND THEY DISCONNECTED THE BATTERY AND LOST RADIO CODE CANT FIND CODE CARD ANYBODY HELP.RADIO SERIAL NUMBER IS M407481.MANY THANKS MICHAEL
  15. Ok guys will give it a go cheers.marrak.