Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Tomo2482

Budding Enthusiast
  • Content count

    7
  • Joined

  • Last visited

About Tomo2482

  • Rank
    Newbie

Profile Information

  • Ford Model
    Fiesta
  1. Bit late replying to this one but I recently got a 2.0 TDCI I put £70 of fuel in and this gave me 540 miles last week that's combined miles with motorway. Really impressed with it only a Zetec spec 2009 model but love it. Sent from my iPhone using Ford OC
  2. Fantastic idea may have a go at this ;-)
  3. Just disconnected 3 amp violet ecu fuse in engine bay and drain has gone down from 3 amp to 1.3 amp car starts and drives fine ? confused ????
  4. Just tried my small 12v tester and only thing drawing a small amount of power is the clock its on all the time so I have disconnected it will see if it starts in the morning !!!!!
  5. Thanks for that I will have a look !!!!!!!
  6. Hi, I have a Fiesta TD 2001 and my battery continually drains overnight unless I disconnect the negative lead. I have had a new alternator, recon starter (tested today its fine), and I am on my second battery. If I leave it connected when I turn the key all the lights come on and the speedo needle goes round but no noise or cranking engine. My garage and a auto electrician can find no drain or fault. Can anyone help all help appreciated.
  7. Fiesta is driving me mad

  8. New to forums so unsure if posted correctly ???

  9. Hi, I have a Fiesta TD 2001 and my battery continually drains overnight unless I disconnect the negative lead. I have had a new alternator, recon starter (tested today its fine), and I am on my second battery. If I leave it connected when I turn the key all the lights come on and the speedo needle goes round but no noise or cranking engine. My garage and a auto electrician can find no drain or fault. Can anyone help all help appreciated. Regards