dan@fastford

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About dan@fastford

  • Rank
    Newbie

Profile Information

  • Ford Model
    Mondeo
  1. Sorry, wheel bearing, not wishbone (can't edit a post on my phone!)
  2. Stef123 - it's one of these... http://www.skyparts.co.uk/parts/2373-hub-nut-ford-focus-fr.html
  3. I strongly suggest taking the centre cap off the wheel and marking its position with tip-ex or similar so you can check it by eye. You don't want it coming loose again as it will very quickly knacker the wishbone. Fingers crossed it was a simple slip up by the mechanic. Also the hub nuts aren't really meant to be reusable, so would be sensible to get another.
  4. 1st and 2nd also have the torque restricted to limit wheelspin. Most remaps simply lift this restriction, so the car feels faster.
  5. This almost certainly isn't a hub nut issue unfortunately - They're tightened to over 300Nm, and they don't just work loose. What's likely to have happend is that the hub flange has worn and the hub nut will keep coming loose. If you don't replace the whole hub you'll eat wheel bearings and hub nuts. Ideally you need a complete replacement hub - you could risk one from eBay. This is the bit that wil have worn (this one's from a Focus, but you get the idea)
  6. I would strongly suggest that you've got a split boost hose. The black smoke, lack of performance and in particular the 'whooshing sound' are all tell tales. It's more likely than not going to be the EGR to intercooler pipe which goes down the front left of the engine. They go for a pastime, and are about £45 from Ford.