Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


vickie321

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About vickie321

  • Rank
    Newbie

Profile Information

  • Ford Model KA
  1. Help

    That picture isnt my car, the fluid in my car in the reservoir that is in the same place as the one on that picture with the black cap on my car contains blue fluid, not dark red or black, if it is power steering fluid could it be blue? And as for the levels, mine is currently well below minimum when the engine is cold, so would i top it up to minimum or to a mid way point between min and max? Thanks for your help. x
  2. Re your problem with stalling ... i had the same problem when i first got my car, turned out to be the accelerator housing, a garage quoted me £200 for a new one, but i since discovered the only real problem was the wire was loose, and found someone who could disassemble the housing and reposition the wire and the problem was solved for a fraction of the price of a new one (bout £20. I think i also have the same 'friction' sound, i describe it as a whirring noise that sounds like its coming from the passenger front wheel, this was caused similarily, from a violent stall, it causes no obvious problems, just irritating and sounds bad, it seems to disappear once i hit 30mph and 3rd or 4th gear, only really seems present when im in low gears and turning in both directions ... hopefully mine will also be fixed by going over a speed bump but i dont hold my breath and turn my music up so as not to be permanently depressed by the noise whilst driving lol x
  3. Help

    So, I have a 2001 Ford Ka 1.3, think its an Endura engine but not 100% (will check) and the symbols have worn off the caps under my bonnet. The one im trying to identify is shown on the attachment below, in the top left of the picture, the one with a black cap inbetween the dip stick and the top strut mount of the suspension. The fluid appears to be blue in colour, i think its radiator fluid but in all honesty i dont have a clue :-( but its below minimum level and i dont want the car to break down or blow up on me so im eager to get it sorted. Thanks in advance!! Vickie x ps. this picture is not my engine, but one ive found using google that looks the same