• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


aidmcn

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About aidmcn

  • Rank
    Newbie

Profile Information

  • Ford Model
    Focus
  1. Hello,

    My name is Justina,i saw your profile today at this site (www.fordownersclub.com) and i love it also became intrested in you,i will also like to know you more,and i want you to send an email directely to my email address so that i can reply your mail and also give you my picture for you to know whom i am.Here is my email address(justinadavids23@yahoo.com) i believe we can mo...

  2. Its already cost £1100, the dealer will supply a warranty with the part butnot confirm that the underlying issue is resolved.
  3. I think the car displays and error code which is something to do with an intrustion attempt
  4. Hi i have a 2005 focus 1.8 tdci which has had an ongoing problem that manefests itself when driving along, the display reads reduced power, followed by power assist failure and ultimately when it stops the message is engine systems fault. At this stage the engine immobiliser light is flashing quickly and the car will not turn over or start. To date the ford dealer has tried the following on the five occasions that it has been towed to the dealership. Reprogramming Keys Replacing the internal fuse box Replacing the battery Soldering some cables he states were loose behind the dash and finally replacing the instrument cluster Does anybody have any knowledge of a similar fault and how to resolve it?