3steps2heaven

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About 3steps2heaven

  • Rank
    Newbie
  • Birthday 10/25/1991

Profile Information

  • Gender*
    Female
  • Ford Model
    Fiesta Zetec Blue (Special Edition) 2008

Previous Fields

  • Location
    Scottish Borders
  1. Thought I would try here for help before taking it to the garage - Car is a fiesta (05-08 model, 1.4L tdci) Problem 1 - it has always got 58-65mpg depending who was driving it. After a minor incident where it clipped a wheel which was in the middle of the road, bursting a tyre (garage found nothing wrong) I changing all 4 tyres the mpg has now dropped to 54-56. The new tyres are Bridgestone turanzas, the old ones were the same but bought part worn. Thought the mpg may have been down to the new tyres, but it has now been about a month and 1500 miles and it is showing no signs of improving. Problem 2 - there is a ticking noise when accelerating. The back box of exhaust was replaced a few months ago, although it sounds more like it is coming from the engine. Have had problems with fuel injector seals, and all 4 have been replaced within the last year. Could be this again? Problem 3 - the car stutters, almost misses sometimes - it is always at 30mph in third when you take your foot off after accelerating, or the same at 40 in 4th. Doesn't happen every time and never at any particular time (does it when engine is hot and cold). Spoke to the garage about it when fuel injectors were done but they didn't find a problem (and it typically didn't do it when I took the mechanic out in it). Any opinions would be appreciated - just wondered if anyone had similar issues/what the cause was.
  2. I am looking to change the wheels on my Fiesta for smaller ones with bigger tyres to cut down on road noise (and tyre cost).. I have the 08 Fiesta Zetec Blue, currently running 16" alloys with 195/45 R16 tyres. I have found some 15" steel wheels with 195/50 R15 tyres from an 06 Fiesta. Does anybody know if it will be possible to do a straight swap? Will the new wheels fit my Fiesta (as both are the same model)? And will the car need reprogramming?/How much will this cost?
  3. Hello,

    My name is Justina,i saw your profile today at this site (www.fordownersclub.com) and i love it also became intrested in you,i will also like to know you more,and i want you to send an email directely to my email address so that i can reply your mail and also give you my picture for you to know whom i am.Here is my email address(justinadavids23@yahoo.com) i believe we can move fro...

  4. I have the 1.4tdci - it's an 08 plate and I bought it in October with 11k on it. I do quite a lot of miles travelling to Edinburgh and back daily. In December/January at about 12-14k miles I noticed an exhaust fume type smell and it was missing when you hit 40mph in 4th gear. The garage confirmed that it was the injector seals and did the necessary work - still under warranty (thankfully!). Now (less than 5 months later, with 20k miles), it has happened again. This time the change seemed to be more sudden, and the smell of diesel is more raw and much stronger. It is also missing occasionally regardless of what speed/gear you are in (usually over 30mph though,not at low speeds). It is still under warranty, but this surely shouldn't have happened twice within 5 months on a car that has such a low mileage? When I researched the problem it seemed common - on cars with about 40k. And although I do a lot of miles, I wouldn't say it was excessive(still only half the mileage the problem seems common at). I am a very careful driver and don't rev it too much etc. My boyfriend also drives it and sometimes revs it a bit, but he's not as bad as many people. Anyone got any advice/had a similar problem? And if so, was it fixed in the end/how? Warranty runs out this summer, so I'm just slightly concerned that it will happen again after it runs out.