• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


KaMinx

New Member
  • Content count

    1
  • Joined

  • Last visited

About KaMinx

  • Rank
    Newbie

Profile Information

  • Ford Model
    Ka
  1. Hello! I'm new to this forum - I have a 2003 Ka Style and have been very happy with it since 2004. However, it seems to be developing some problems, maybe due to its age? My car is sometimes very hesitant when setting off from slow or stopped - almost like it is lacking in power or misfiring - this can be quite dangerous when pulling out of a junction or away from a roundabout as I get stranded in the middle of the road unable to accelerate away. The worst time this happened, the engine warning light came on, and I had to take it to the Ford garage. They diagnosed a blocked injector nozzle and changed it, but the problem came back just a couple of weeks later. It is intermittant, so it's difficult to show a mechanic, as the problem is not always apparent. It has now developed a squeaky noise on setting off (a bit like a belt slipping), and this noise also sounds when I change from 2nd/3rd or 3rd/4th when the car's in motion. Has anyone else experienced this / can anyone help? And just to add everyone's favourite Ka job, is it feasible for me to change the headlights/indicators myself - by taking the bumper off - or does it need to go to the garage AGAIN? Hope someone is able to help. Good to see an accessible forum too!