jab25bike

Budding Enthusiast
  • Content count

    13
  • Joined

  • Last visited

About jab25bike

  • Rank
    Member

Contact Methods

  • First Name
    james

Profile Information

  • Gender*
    Male
  • Ford Model
    fiesta
  • Ford Year
    1997
  • UK/Ireland Location
    Warwickshire
  • Annual Mileage
    0 to 5000
  1. a while back i had problems with my fiesta not going above 30 mph. well i seem to have solved the problem with the help of my local garage it turned out it was down to the rear box collaped,after i had tride and changed most parts.i would just like to thank those who offered there help and advise,cheers.
  2. hi again,hoping now solved prolem with fiesta not going above 30mph,turned out to be middle and back exaust baffles. had new pipe fitted andb all is well,after all that playing about.a big thanks to you who offered some advise.

  3. ok thanks will look into it and let u know the out come if ever i get it sorted.
  4. have now tried disconecting the battery,but still no difference,still starts and runs ok but no power after 30-40mph.
  5. hi thank you both for your replies,will give it a go this weekend and let you know how i get on .cheers.
  6. hi there i wish some one could help me,ihave a p reg fiesta that will start and run no matter how long it's left,the trouble is it does not have any guts when you get upto 30mph.have changed plugs,air filter,fuel filter.put on differrent mass air senser and catt all not making any difference.there no miafire or surging of any kind.help.
  7. hi there still having trouble with my fiesta,starts fist time any time no matter how long its left but the trouble is there no power above 30 mph,have changed the plugs,fuel filter,air filter and have just changed the catt-pipe ,all of which have made no difference.i have been told to try swapping the mass air senser. i hope someone out there can help me.26/7/11 have now changed mass air senser but still no difference.help.5/9/11 still having this problem.
  8. thanks for that will give it ago when i get chance.cheers.
  9. thanks for your responce ,can push car so brakes are not binding,there is slight tappet rattle but not to much.would coil pack be a problem with it starting and running so easily.i just dont know.
  10. 1st timer,hi to you all.fiesta 1.3 starts ok and runs no matter how long you leave it,problem is no power after about 45mph,have done plugs,fuel filter,air filter.problem only been doing very short journeys.