• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


john49

Members via FB
  • Content count

    3
  • Joined

  • Last visited

About john49

  • Rank
    Newbie

Contact Methods

  • First Name
    John

Profile Information

  • Gender*
    Male
  • Ford Model
    Galaxy
  • Ford Year
    2001
  • UK/Ireland Location
    Kent
  • Interests
    Motorsport & Racing
    Travel
    Computers & Electronics
    Arts & Crafts
  1. Radio Code

    Hi, can anyone help me with the radio code as Ive lost it. Radio model M383588 thanks
  2. Galaxy Wiper Issues

    Hi Yoda, same thing happened to me last year and its the bearings seizing up on the wiper mechanism. I've heard that you can sometimes free them up by greasing them but dont know how as mine were replaced by AA on a servie plan John49
  3. Hi, I have been having problems with my auto box for some time now it started as a kick/thump when 5th gear was engaged and went on to reverse gear sometimes not engaging and sounds like the belts slipping when accelerating and then releasing the pedal. I went to a garage last october and they changed the g/box with a reconditioned one (so I was told!) but the problems have come back and of course the waranty has expired. I've noticed on the S-Max forum that they have been having the same problems on their g/boxes and that there may be a problem with the modules communicating with each other and not the g/box needing to be replaced. I 've sent a PM to a member there but if anyone else has some useful info I'd be very grateful.