• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


bighangover

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About bighangover

  • Rank
    Newbie

Contact Methods

  • First Name
    Chris

Profile Information

  • Gender*
    Male
  • Ford Model
    Galaxy
  • Ford Year
    2000
  • UK/Ireland Location
    Devon
  1. Bodged Wiring

    hope someone can help. i brought a galaxy 3 weeks ago. it's one of those "the more you look,the more you find" i'm trying to deal with issues one by one. the car has a standard ford cassette player with only sound from the dash speakers & roof mounted dvd screen, there is no cable plugged into it, so i'm assumming it's DOA. the dvd player that would have been under the passenger seat is missing. the previous owner had unplugged some bits and chopped the other wiring. i pulled the stereo out and have found choc block heaven, there is not a single cable that does not have a join or spur. i'm looking to chop out everything and revert to a standard iso. does anyone know what colours i need to keep an eye out four. the cd changer is also missing, so i assumme some of the cables are for that, hope you can help.Galaxy TDI 2000 (W)
  2. Galaxy Wiper Issues

    i had a similar issue, i opened the bonnet and using WD40 and straw, sprayed everything connected to the wipers that should move. i went OTT, but felt that the cost of half a can of WD was worth it. 3 weeks on, they're still working fine