Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


Juanpablo

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

About Juanpablo

  • Rank
    Newbie

Profile Information

  • Ford Model
    2000 zetec s 2008 zetec blue
  1. Could you have set the clip lower at some point. Enter the menu, I think its the next option after clock settings, then you can adjust clip level or turn it off completely.
  2. Our new Zetec blue 1.4 (June 08) - 2300 miles, commute to station 5miles of 30/40 mph limit. I have always brimmed my cars tank to calculate consumption and find the Fiesta fuel readout to be pretty accurate - this returning 39 - 43mpg. Prior vehicle 1998 1.25 Zetec returned the same figures for the 9 years we owned it but it was driven quicker as the 40mph limit was changed from 60mph recently. Interestingly enough owned a 1990 fiesta Turbo with 185 bhp and it returned 38 mpg on the same run. I think the difference is the volume of traffic on the roads, places where Id be in 5th gear at 30mph last year now require 2nd and 3 sets of traffic lights have been installed over the last couple of years. Did 20 miles of 60mph motorway driving on Saturday and the display showed 48 mpg.Wife went to shops then her mothers on Sunday - its now reading 42. My 2000 Zetec S - 29000 miles is used mainly to do 56 miles of motorway driving at 65 mph and usually returns 47 mpg. I do think you will see a 2/3 mpg increase as the engine slackens off. Dave
  3. My Wife's Zetec Blue with the Sony system has done the same thing 3 or 4 times. This car is used daily for our commute to the station and for the Tesco trips. Try opening the passenger door or turning the ignition on/off/on before starting the engine - either has brought the Sony to life, not ideal but I thought that taking it back to Ford would just cause grief - you have just confirmed my fears. Would appreciate it if you could post the fix to the problem - best of luck! Dave
  4. I have a 2000 Zetec S from new and my Brother in law bought a Puma a few months later - they both made this noise when starting off from cold or after sitting for 15 minutes or so.It was well documented back then and apparently is the abs self checking - my fiesta still does it at about 15mph and I almost think I can feel it through the car. I check the abs once a year on wet cobblestones near my home (kinder to tyres than a grippy surface) and it works ok. Hope this helps to put your mind at rest. JP