• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


ian martin

New Member
  • Content count

    1
  • Joined

  • Last visited

About ian martin

  • Rank
    Newbie

Profile Information

  • Ford Model
    focus
  1. dashboard starting problems

    Please can somebody help me as im about to go mad!!!!!!!!! I have a 2003 1.8 tdci zetec with the usual dashboard problems, but after cleaning the connections and putting it all back together all was great when i turned the ignition on. But when i went to start it for a second everything seemed perfect until the engine cut out after a few seconds, and now whenever i try to start the car with the dashboard connected its a non runner. Disconnect the dash board cluster and the car runs great until you plug it back in and then 2 seconds or so and it stops the engine dead. i thought it was something todo with the immobiliser but i didnt think the cluster affected it? Please can somebody help me?????