Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


ronnie2345

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About ronnie2345

  • Rank
    Newbie
  • Birthday 07/10/1990

Contact Methods

  • First Name
    ronnie

Profile Information

  • Gender*
    Male
  • Ford Model
    mondeo
  • Ford Year
    2001
  • UK/Ireland Location
    Durham
  • Annual Mileage
    5001 to 10,000
  • Interests
    Classic Cars
    General Automotive
    Motorsport & Racing
    Car Restoration
    Car Modification
    Road Trips

Previous Fields

  • Location
    north east
  1. it the sender next to the tank i had the same problem
  2. thanks a will try that today
  3. i have owned my 51 plate mondeo tddi for a week it has run with out any problems untill yesterday when i was driveing it started jumping and there was lots of white smoke and then cut out. i took return pipe off filter it was empty if i fill it up it will start then cut out when it is empty then not start again untill i fill filter i have tryed changeing the filter but there is no diffrance any ideas would great thanks
  4. it could be termostat or waterpump take termostat out and run the car to see if it heats up